summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2020-04-26 17:06:52 +0100
committerDiab Neiroukh2020-04-26 17:06:52 +0100
commit354fdd30bb669db78399cdda22a7226bd24f035a (patch)
tree943634675b3665d929477f3e47997635a32e14af
parent36d8a431d931b9f184666102a0a60de452018ae1 (diff)
downloadaur-354fdd30bb669db78399cdda22a7226bd24f035a.tar.gz
🚀 RELEASE: The first complete release of NGINX Zest for Arch
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e20c6c7b68b..1d3e995e1b9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-zest-git
pkgver = 1.17.10
- pkgrel = 3
- epoch = 2
+ pkgrel = 1
+ epoch = 3
url = https://github.com/ZestProjects/nginx
arch = x86_64
license = custom
@@ -15,6 +15,7 @@ pkgbase = nginx-zest-git
source = git+https://github.com/ZestProjects/nginx.git
source = git+https://github.com/AirisX/nginx_cookie_flag_module.git
source = git+https://github.com/cloudflare/quiche.git
+ source = git+https://github.com/cloudflare/zlib.git
source = git+https://github.com/google/ngx_brotli.git
source = git+https://github.com/masonicboom/ipscrub.git
source = git+https://github.com/openresty/echo-nginx-module.git
@@ -44,6 +45,7 @@ pkgbase = nginx-zest-git
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
+ b2sums = SKIP
b2sums = fbd993990b43a4476d0963287bdc5f55f73fa5ce828f11977cf1abeedd478729a95861d930e27c6a1b0e78b16397164395afc4473fd34e050cadd32b94336beb
b2sums = ea3b5668b18b83df37bd954bd7cfd61fcb91e7b40bc2ef79f7c2117252307bbd716925669e15331a813eadb07819e5a3a7410eab52e8f918a167fe69ead2b375
b2sums = fe32fb75a7677abca86c4bc3f4ca9bfeccb3cd7afb4dd3c4ec21ab8b53cc0d72ba5330a1131498b5df222c2e517bd01e2df9f67256011ff15241b777a85be6b3
@@ -59,7 +61,6 @@ pkgname = nginx-zest-git
depends = liburing
depends = mailcap
depends = pcre
- depends = zlib
depends = zstd
optdepends = nginx-zest-src-git: dynamic module support
provides = nginx=1.17.10
diff --git a/PKGBUILD b/PKGBUILD
index 196c862d3313..9544f8c70fd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@ pkgname=(
"nginx-zest-src-git"
)
pkgver=1.17.10
-pkgrel=3
-epoch=2
+pkgrel=1
+epoch=3
arch=(
"x86_64"
)
@@ -29,9 +29,10 @@ makedepends=(
"rust>=1.39"
)
source=(
- "git+${url}.git"
+ "git+$url.git"
"git+https://github.com/AirisX/nginx_cookie_flag_module.git"
"git+https://github.com/cloudflare/quiche.git"
+ "git+https://github.com/cloudflare/zlib.git"
"git+https://github.com/google/ngx_brotli.git"
"git+https://github.com/masonicboom/ipscrub.git"
"git+https://github.com/openresty/echo-nginx-module.git"
@@ -63,6 +64,7 @@ b2sums=(
"SKIP"
"SKIP"
"SKIP"
+ "SKIP"
"fbd993990b43a4476d0963287bdc5f55f73fa5ce828f11977cf1abeedd478729a95861d930e27c6a1b0e78b16397164395afc4473fd34e050cadd32b94336beb"
"ea3b5668b18b83df37bd954bd7cfd61fcb91e7b40bc2ef79f7c2117252307bbd716925669e15331a813eadb07819e5a3a7410eab52e8f918a167fe69ead2b375"
"fe32fb75a7677abca86c4bc3f4ca9bfeccb3cd7afb4dd3c4ec21ab8b53cc0d72ba5330a1131498b5df222c2e517bd01e2df9f67256011ff15241b777a85be6b3"
@@ -119,6 +121,7 @@ _zest_flags=(
--with-libatomic
--with-openssl="../quiche/deps/boringssl"
--with-quiche="../quiche"
+ --with-zlib="../zlib"
)
prepare()
@@ -132,13 +135,17 @@ prepare()
#* Checkout to a newer BoringSSL to fix an error that Clang picks up
git checkout 21f694210c9232d6ab926d029c315ae6069c7dbb
+
+ cd "../../../zlib" || exit
+ [ -f Makefile ] && make clean
+ make -f Makefile.in distclean
}
build()
{
#* Manually state the compiler flags
- export CFLAGS="-O3 -pipe -fno-plt"
- export CXXFLAGS="-O3 -pipe -fno-plt"
+ export CFLAGS="-march=x86-64 -mtune=generic -O3 -pipe -fno-plt"
+ export CXXFLAGS="-march=x86-64 -mtune=generic -O3 -pipe -fno-plt"
cd "nginx" || exit
./auto/configure \
@@ -185,7 +192,6 @@ package_nginx-zest-git()
"liburing"
"mailcap"
"pcre"
- "zlib"
"zstd"
)
optdepends=(