summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2020-11-04 17:17:48 +0000
committerDiab Neiroukh2020-11-04 17:17:48 +0000
commit9a953ce6d86340c3e4bfbe30d182cf2ded79edfb (patch)
tree7980a216d3c764c9a86793662b57766cdf25c4df
parent483c7eac7d48659fe16b84213e5c75d652601eb2 (diff)
downloadaur-9a953ce6d86340c3e4bfbe30d182cf2ded79edfb.tar.gz
👌 IMPROVE: Switch to mimalloc for memory allocation
mimalloc performs better than TCMalloc for all but Redis tests, so it's good for us here. Signed-off-by: Diab Neiroukh <lazerl0rd@thezest.dev>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88995eca1a84..014abbf7ede4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-zest-git
pkgdesc = NGINX with beefed up security and performance
- pkgver = 1.19.4.r0.gb3f311dd8
- pkgrel = 7
+ pkgver = 1.19.4.r0.g27ce47d2b
+ pkgrel = 8
epoch = 3
url = https://github.com/ZestProjects/nginx
install = nginx.install
@@ -24,7 +24,7 @@ pkgbase = nginx-zest-git
depends = mailcap
depends = libxcrypt
depends = brotli
- depends = gperftools
+ depends = mimalloc
depends = liburing
depends = zstd
provides = nginx
@@ -62,7 +62,7 @@ pkgbase = nginx-zest-git
pkgname = nginx-zest-git
pkgname = nginx-zest-src-git
- pkgdesc = Source code of Zest NGINX 1.19.4.r0.gb3f311dd8, useful for building modules
+ pkgdesc = Source code of Zest NGINX 1.19.4.r0.g27ce47d2b, useful for building modules
depends =
provides = nginx-src
provides = nginx-mainline-src
diff --git a/PKGBUILD b/PKGBUILD
index f3032d2f7094..e61167d28083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@
pkgbase=nginx-zest-git
pkgname=(nginx-zest-git nginx-zest-src-git)
-pkgver=1.19.4.r0.gb3f311dd8
-pkgrel=7
+pkgver=1.19.4.r0.g27ce47d2b
+pkgrel=8
epoch=3
pkgdesc='NGINX with beefed up security and performance'
arch=(x86_64)
url='https://github.com/ZestProjects/nginx'
license=(custom)
-depends=(pcre openssl geoip mailcap libxcrypt brotli gperftools liburing zstd)
+depends=(pcre openssl geoip mailcap libxcrypt brotli mimalloc liburing zstd)
makedepends=(mercurial git 'rust>=1.39')
checkdepends=(perl perl-gd perl-io-socket-ssl perl-fcgi perl-cache-memcached
memcached ffmpeg inetutils)
@@ -111,9 +111,7 @@ build() {
export CFLAGS="${CFLAGS//-flto=thinlto/}" # thinlto also breaks quiche
export CXXFLAGS="${CXXFLAGS//-fltothinlto/}" # thinlto also breaks quiche
- export CFLAGS="$CFLAGS -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free" # recommended for tcmalloc
- export CXXFLAGS="$CXXFLAGS -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free" # recommended for tcmalloc
- export LDFLAGS="$LDFLAGS -ltcmalloc" # needed for tcmalloc
+ export LDFLAGS="$LDFLAGS -lmimalloc" # use mimalloc as the memory allocator
cd nginx