summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorapolih2016-01-29 16:47:15 -0600
committerapolih2016-01-29 16:47:15 -0600
commit6f5cfb0b88fbf246df32b5b72206906fd2f677d5 (patch)
tree3eafdc9480a48bb3e19fd748ab5b33ffa24a9d0f
downloadaur-6f5cfb0b88fbf246df32b5b72206906fd2f677d5.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--ngs.patch91
3 files changed, 162 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9658a5cc7f1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 22:47:08 UTC 2016
+pkgbase = ngs
+ pkgdesc = A new, domain-specific API for accessing reads, alignments and pileups produced from Next Generation Sequencing.
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = https://github.com/ncbi/ngs
+ arch = x86_64
+ license = custom:PublicDomain
+ depends = java-environment
+ depends = perl-file-copy-recursive
+ depends = zlib
+ provides = ngs
+ source = https://github.com/ncbi/ngs/archive/1.2.3.tar.gz
+ source = ngs.patch
+ sha256sums = 625ec04737dea787f3800744f1d5fddb4d83b21013c281bcbc8691149b230794
+ sha256sums = 9e4356666dbe7fc01dfcfaad914b108777164c464a77776742fae78da369a352
+
+pkgname = ngs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bc424613f71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# This is the PKGBUILD for ngs
+# Maintainer: Aaron Baker <aa{last name}99{at}gmail{dt}org>
+
+pkgname=ngs
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="A new, domain-specific API for accessing reads, alignments and pileups produced from Next Generation Sequencing."
+arch=('x86_64')
+url="https://github.com/ncbi/ngs"
+depends=('java-environment' 'perl-file-copy-recursive' 'zlib')
+provides=('ngs')
+license=('custom:PublicDomain')
+source=("https://github.com/ncbi/ngs/archive/$pkgver.tar.gz" "$pkgname.patch")
+sha256sums=('625ec04737dea787f3800744f1d5fddb4d83b21013c281bcbc8691149b230794' '9e4356666dbe7fc01dfcfaad914b108777164c464a77776742fae78da369a352')
+
+prepare(){
+ cd "${pkgname}-${pkgver}"
+ # ncbi build process frequently checks if we are root user which interferes
+ # with makepkg use of fakeroot
+ patch -p1 -i $srcdir/$pkgname.patch
+}
+
+build(){
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix="$pkgdir/usr/"
+ cd "ngs-java"
+ ./configure --prefix="$pkgdir/usr/"
+ cd ".."
+ make
+}
+
+check(){
+ cd "${pkgname}-${pkgver}"
+ make -k test
+}
+
+package(){
+ cd "$pkgname-$pkgver"
+ # ncbi does not use autoconf/automake so there is no respect for DESTDIR
+ # but there is a ROOT(dir)
+ make "ROOT=$pkgdir" install
+
+ # add license
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
+ cp "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+
+ # reorganize files from build process to fit Arch
+ mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+ mkdir -p "$pkgdir/usr/share/java"
+ mv "$pkgdir/usr/jar" "$pkgdir/usr/share/java/$pkgname"
+}
diff --git a/ngs.patch b/ngs.patch
new file mode 100644
index 000000000000..02c712298162
--- /dev/null
+++ b/ngs.patch
@@ -0,0 +1,91 @@
+diff -aur ngs-1.2.3.pristine/Makefile ngs-1.2.3.new/Makefile
+--- ngs-1.2.3.pristine/Makefile 2015-11-23 18:38:45.000000000 +0000
++++ ngs-1.2.3.new/Makefile 2016-01-25 21:42:41.455818616 +0000
+@@ -29,7 +29,6 @@
+ SUBDIRS = \
+ ngs-sdk \
+ ngs-java \
+- ngs-python \
+ ngs-bam
+
+ SUBDIRS_CLN = \
+diff -aur ngs-1.2.3.pristine/ngs-bam/setup/install.perl ngs-1.2.3.new/ngs-bam/setup/install.perl
+--- ngs-1.2.3.pristine/ngs-bam/setup/install.perl 2015-11-23 18:38:45.000000000 +0000
++++ ngs-1.2.3.new/ngs-bam/setup/install.perl 2016-01-25 22:20:30.522404231 +0000
+@@ -81,11 +81,9 @@
+ prepare();
+
+ my $LINUX_ROOT;
+-++$LINUX_ROOT if (linux_root());
+ my $ROOT = '';
+ if ($OPT{root}) {
+ $ROOT = "$OPT{root}/root";
+- ++$LINUX_ROOT;
+ foreach ("$ROOT/usr/include", "$ROOT/etc/profile.d") {
+ unless (-e $_) {
+ print "mkdir -p $_... ";
+diff -aur ngs-1.2.3.pristine/ngs-java/Makefile.java ngs-1.2.3.new/ngs-java/Makefile.java
+--- ngs-1.2.3.pristine/ngs-java/Makefile.java 2015-11-23 18:38:45.000000000 +0000
++++ ngs-1.2.3.new/ngs-java/Makefile.java 2016-01-25 21:16:43.505874267 +0000
+@@ -59,12 +59,13 @@
+ JAR_TARGET = $(INST_JARDIR)/ngs-java.jar
+ DOC_TARGET = $(INST_SHAREDIR)/doc/
+
+-ifeq (linux, $(OS))
+- ifeq (0, $(shell id -u))
+- LINUX_ROOT = true
+- DOC_TARGET = $(ROOT)/usr/local/share/doc/ngs/
+- endif
+-endif
++#ifeq (linux, $(OS))
++# ifeq (0, $(shell id -u))
++# LINUX_ROOT = true
++# DOC_TARGET = $(ROOT)/usr/local/share/doc/ngs/
++# endif
++#endif
++LINUX_ROOT = false
+
+ install: $(TARGETS) $(INST_JARDIR) $(INST_JARDIR)/ngs-java.jar.$(VERSION) copydocs copyexamples
+ ifeq (true, $(LINUX_ROOT))
+diff -aur ngs-1.2.3.pristine/ngs-python/Makefile.python ngs-1.2.3.new/ngs-python/Makefile.python
+--- ngs-1.2.3.pristine/ngs-python/Makefile.python 2015-11-23 18:38:45.000000000 +0000
++++ ngs-1.2.3.new/ngs-python/Makefile.python 2016-01-25 21:19:48.709200984 +0000
+@@ -56,7 +56,7 @@
+ install: $(TARGETS) $(INST_PYTHONDIR) copyexamples
+ ifeq (0, $(shell id -u))
+ @ echo "Installing ngs-python package..."
+- @ python setup.py -q install
++ @ python setup.py -q install --root="$pkgdir/"
+
+ else
+ @ echo "Installing ngs-python package..."
+@@ -78,7 +78,7 @@
+ install: $(TARGETS) $(INST_PYTHONDIR) copyexamples
+ ifeq (0, $(shell id -u))
+ @ echo "Installing ngs package..."
+- @ python setup.py -q install
++ @ python setup.py -q install --root="$pkgdir/"
+
+ else
+ @ echo "Installing ngs package..."
+diff -aur ngs-1.2.3.pristine/ngs-sdk/Makefile.install ngs-1.2.3.new/ngs-sdk/Makefile.install
+--- ngs-1.2.3.pristine/ngs-sdk/Makefile.install 2015-11-23 18:38:45.000000000 +0000
++++ ngs-1.2.3.new/ngs-sdk/Makefile.install 2016-01-25 21:09:31.642556359 +0000
+@@ -63,11 +63,12 @@
+ INCLUDE_SYMLINK = $(ROOT)/usr/include/ngs
+ PROFILE_FILE = $(ROOT)/etc/profile.d/ngs-sdk
+
+-ifeq (linux, $(OS))
+- ifeq (0, $(shell id -u))
+- LINUX_ROOT = true
+- endif
+-endif
++LINUX_ROOT = false
++#ifeq (linux, $(OS))
++# ifeq (0, $(shell id -u))
++# LINUX_ROOT = true
++# endif
++#endif
+
+ install: copylibs copyincludes copyexamples
+ ifeq (true, $(LINUX_ROOT))