summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Amanakis2019-05-28 13:58:21 -0400
committerGeorge Amanakis2019-05-28 13:58:21 -0400
commitc09214fb07e894306e80d955dd7c589281a1fd49 (patch)
treeed59b5cb3f72dfc3d1cdd50a8d7e97ab3f57cddf
downloadaur-c09214fb07e894306e80d955dd7c589281a1fd49.tar.gz
Initial commit for ngs-python, 2.9.6
Signed-off-by: George Amanakis <gamanakis@gmail.com>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
-rw-r--r--ngs-python.patch30
-rw-r--r--ngs.patch65
4 files changed, 169 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38be1b48b052
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ngs-python
+ pkgdesc = A new, domain-specific API for accessing reads, alignments and pileups produced from Next Generation Sequencing.
+ pkgver = 2.9.6
+ pkgrel = 1
+ url = https://github.com/ncbi/ngs
+ arch = x86_64
+ license = custom:PublicDomain
+ depends = java-environment
+ depends = perl-file-copy-recursive
+ depends = zlib
+ depends = ncbi-vdb
+ depends = ngs
+ provides = ngs-python
+ source = https://github.com/ncbi/ngs/archive/2.9.6.tar.gz
+ source = ngs.patch
+ source = ngs-python.patch
+ md5sums = d87f96dcfcaf4967ddbbf8de761641f8
+ md5sums = 3973d35d7a1b252eb6a426403a652ef9
+ md5sums = 105d75eb6e144af86569e1240e959702
+
+pkgname = ngs-python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7432e9ef6183
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# This is the PKGBUILD for ngs-python
+# Maintainer: Georgios Amanakis <g_amanakis{at}yahoo{dt}com>
+
+pkgname=ngs-python
+_pkgname=ngs
+pkgver=2.9.6
+pkgrel=1
+pkgdesc="A new, domain-specific API for accessing reads, alignments and pileups produced from Next Generation Sequencing."
+arch=('x86_64')
+url="https://github.com/ncbi/ngs"
+depends=('java-environment' 'perl-file-copy-recursive' 'zlib' 'ncbi-vdb' 'ngs')
+provides=('ngs-python')
+license=('custom:PublicDomain')
+source=("https://github.com/ncbi/ngs/archive/$pkgver.tar.gz" "ngs.patch" "ngs-python.patch")
+md5sums=('d87f96dcfcaf4967ddbbf8de761641f8'
+ '3973d35d7a1b252eb6a426403a652ef9'
+ '105d75eb6e144af86569e1240e959702')
+
+prepare(){
+ cd "${_pkgname}-${pkgver}"
+ # ncbi build process frequently checks if we are root user which interferes
+ # with makepkg use of fakeroot
+ patch -p1 -i $srcdir/ngs.patch
+ patch -p1 -i $srcdir/ngs-python.patch
+}
+
+build(){
+ cd "${_pkgname}-${pkgver}"
+ ./configure --prefix="$pkgdir/usr/" --build-prefix="$srcdir/build"
+ cd ./ngs-python
+ ./configure --prefix="$pkgdir/usr/" --build-prefix="$srcdir/build" --with-ngs-sdk-prefix="/usr" --with-ncbi-vdb-prefix="/usr"
+ cd ../
+ make -C ngs-sdk
+ make -C ngs-python
+}
+
+#check(){
+# cd "${pkgname}-${pkgver}"
+# make -k test
+#}
+
+package(){
+ cd "$_pkgname-$pkgver"
+ # ncbi does not use autoconf/automake so there is no respect for DESTDIR
+ # but there is a ROOT(dir)
+ #make "ROOT=$pkgdir" install
+ make -C ngs-python install
+
+ # add license
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
+ cp "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/ngs-python.patch b/ngs-python.patch
new file mode 100644
index 000000000000..4d5f49c7e470
--- /dev/null
+++ b/ngs-python.patch
@@ -0,0 +1,30 @@
+--- a/ngs-python/setup.py 2019-03-18 12:37:12.000000000 -0400
++++ b/ngs-python/setup.py 2019-05-28 13:09:44.344531737 -0400
+@@ -17,7 +17,6 @@
+ author='sra-tools',
+ author_email='sra-tools@ncbi.nlm.nih.gov',
+ packages=['ngs'],
+- include_package_data=True,
+ scripts=[],
+ #test_suite="tests",
+ )
+
+--- a/ngs-python/Makefile.python 2019-05-28 13:42:40.144181446 -0400
++++ b/ngs-python/Makefile.python 2019-05-28 13:41:25.357950185 -0400
+@@ -79,14 +79,8 @@
+ @ mkdir -p $@
+
+ install: $(TARGETS) $(INST_PYTHONDIR) copyexamples
+-ifeq (0, $(shell id -u))
+- @ echo "Installing ngs package..."
+- @ python setup.py -q install --root="$pkgdir/"
+-
+-else
+- @ echo "Installing ngs package..."
+- @ python setup.py -q install --user
+-endif
++ @ echo "Installing ngs package..."
++ @ python setup.py -q install --root=$(subst usr/,,$(INST_PYTHONDIR))
+
+ ifneq (, $(NGS_LIBDIR))
+ ifneq (, $(VDB_LIBDIR))
diff --git a/ngs.patch b/ngs.patch
new file mode 100644
index 000000000000..27bcb5497b44
--- /dev/null
+++ b/ngs.patch
@@ -0,0 +1,65 @@
+diff -aur ngs-1.2.5.pristine/ngs-java/Makefile.java ngs-1.2.5.new/ngs-java/Makefile.java
+--- ngs-1.2.5.pristine/ngs-java/Makefile.java 2016-07-15 18:45:56.228525816 +0000
++++ ngs-1.2.5.new/ngs-java/Makefile.java 2016-07-15 18:46:43.595193491 +0000
+@@ -59,12 +59,13 @@
+ JAR_TARGET = $(INST_JARDIR)/ngs-java.jar
+ DOC_TARGET = $(INST_SHAREDIR)/doc/
+
+-ifeq (linux, $(OS))
+- ifeq (0, $(shell id -u))
+- LINUX_ROOT = true
+- DOC_TARGET = $(ROOT)/usr/local/share/doc/ngs/
+- endif
+-endif
++#ifeq (linux, $(OS))
++# ifeq (0, $(shell id -u))
++# LINUX_ROOT = true
++# DOC_TARGET = $(ROOT)/usr/local/share/doc/ngs/
++# endif
++#endif
++LINUX_ROOT = false
+
+ install: $(TARGETS) $(INST_JARDIR) $(INST_JARDIR)/ngs-java.jar.$(VERSION) copydocs copyexamples
+ ifeq (true, $(LINUX_ROOT))
+diff -aur ngs-1.2.5.pristine/ngs-python/Makefile.python ngs-1.2.5.new/ngs-python/Makefile.python
+--- ngs-1.2.5.pristine/ngs-python/Makefile.python 2016-07-15 18:45:56.235192482 +0000
++++ ngs-1.2.5.new/ngs-python/Makefile.python 2016-07-15 18:47:44.511861457 +0000
+@@ -56,7 +56,7 @@
+ install: $(TARGETS) $(INST_PYTHONDIR) copyexamples
+ ifeq (0, $(shell id -u))
+ @ echo "Installing ngs-python package..."
+- @ python setup.py -q install
++ @ python setup.py -q install --root="$pkgdir/"
+
+ else
+ @ echo "Installing ngs-python package..."
+@@ -78,7 +78,7 @@
+ install: $(TARGETS) $(INST_PYTHONDIR) copyexamples
+ ifeq (0, $(shell id -u))
+ @ echo "Installing ngs package..."
+- @ python setup.py -q install
++ @ python setup.py -q install --root="$pkgdir/"
+
+ else
+ @ echo "Installing ngs package..."
+diff -aur ngs-1.2.5.pristine/ngs-sdk/Makefile.install ngs-1.2.5.new/ngs-sdk/Makefile.install
+--- ngs-1.2.5.pristine/ngs-sdk/Makefile.install 2016-07-15 18:45:56.248525816 +0000
++++ ngs-1.2.5.new/ngs-sdk/Makefile.install 2016-07-15 18:48:18.855195523 +0000
+@@ -63,11 +63,12 @@
+ INCLUDE_SYMLINK = $(ROOT)/usr/include/ngs
+ PROFILE_FILE = $(ROOT)/etc/profile.d/ngs-sdk
+
+-ifeq (linux, $(OS))
+- ifeq (0, $(shell id -u))
+- LINUX_ROOT = true
+- endif
+-endif
++#ifeq (linux, $(OS))
++# ifeq (0, $(shell id -u))
++# LINUX_ROOT = true
++# endif
++#endif
++LINUX_ROOT = false
+
+ install: copylibs copyincludes copyexamples
+ ifeq (true, $(LINUX_ROOT))