summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Reisner2019-08-04 16:41:51 -0400
committerDave Reisner2019-08-04 16:41:51 -0400
commitf12e6b5bc1dffe2fcca3a2f82d517b73ac8b39b6 (patch)
treebb6cef0922202b3a865692c170a489286129033e
downloadaur-f12e6b5bc1dffe2fcca3a2f82d517b73ac8b39b6.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD52
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4629dcb6f2d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ngtcp2-git
+ pkgdesc = An effort to implement IETF QUIC protocol
+ pkgver = r1467.2d150d1
+ pkgrel = 1
+ url = https://github.com/ngtcp2/ngtcp2
+ arch = x86_64
+ license = GPL
+ checkdepends = cunit
+ makedepends = git
+ provides = ngtcp2
+ provides = libngtcp2.so
+ conflicts = ngtcp2
+ source = git+https://github.com/ngtcp2/ngtcp2
+ md5sums = SKIP
+
+pkgname = ngtcp2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87fc916fd891
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Dave Reisner <d@falconindy.com>
+
+pkgname=ngtcp2-git
+pkgver=r1467.2d150d1
+pkgrel=1
+pkgdesc="An effort to implement IETF QUIC protocol"
+arch=(x86_64)
+url="https://github.com/ngtcp2/ngtcp2"
+license=('GPL')
+makedepends=('git')
+checkdepends=('cunit')
+provides=('ngtcp2' 'libngtcp2.so')
+conflicts=('ngtcp2')
+source=('git+https://github.com/ngtcp2/ngtcp2')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ngtcp2
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ngtcp2
+
+ # don't build the examples to avoid dependency on nghttp3
+ # https://github.com/ngtcp2/ngtcp2/pull/140
+ sed -i '/SUBDIRS/ s/examples//' Makefile.am
+}
+
+build() {
+ cd ngtcp2
+
+ autoreconf -fisv
+
+ ./configure \
+ --prefix=/usr
+
+ make
+}
+
+check() {
+ cd ngtcp2
+
+ make -k check
+}
+
+package() {
+ cd ngtcp2
+
+ make DESTDIR="$pkgdir" install
+}