summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPuckel2015-11-12 16:43:25 +0100
committerPuckel2015-11-12 16:45:35 +0100
commitf3fd6b23d09f5d626204306a5c4714eca500ea75 (patch)
tree49027243f26c4822b1512aadf2accda0cfe5bca4
downloadaur-f3fd6b23d09f5d626204306a5c4714eca500ea75.tar.gz
Initial Import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f871e507b8f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ngxtop
+ pkgdesc = Real-time metrics for nginx server
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/lebinh/ngxtop
+ arch = any
+ license = MIT
+ depends = python2-setuptools
+ depends = python2-pyparsing
+ depends = python2-tabulate
+ source = http://pypi.python.org/packages/source/n/ngxtop/ngxtop-0.0.2.tar.gz
+ md5sums = 9758ff9c8163024a5a9b30df9fb6eedc
+
+pkgname = ngxtop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0a19efebbc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Matthieu "Puckel_" Roisil <contact@puckel.fr>
+
+pkgname=ngxtop
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Real-time metrics for nginx server"
+arch=('any')
+url="https://github.com/lebinh/ngxtop"
+license=('MIT')
+
+depends=(
+ 'python2-setuptools'
+ 'python2-pyparsing'
+ 'python2-tabulate'
+)
+source=("http://pypi.python.org/packages/source/n/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('9758ff9c8163024a5a9b30df9fb6eedc')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ find -type f -name "*.py" -exec sed -i 's|/usr/bin/env python|/usr/bin/env python2|' {} \;
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install -O1 --skip-build --prefix=/usr --root="$pkgdir"
+}