summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-04-23 23:22:50 +0200
committerNarrat2020-04-23 23:22:50 +0200
commitcf536a2ecf0f488b1bfc297bc2cf6aa36d183ea1 (patch)
tree15031a12338325a071c9931b149ee3400b1acd36
downloadaur-cf536a2ecf0f488b1bfc297bc2cf6aa36d183ea1.tar.gz
ngxtop-ce: Initial commit
Community-edition? At least some progress. Time will tell, if it stays alive but at least it is in a better shape than ngxtop.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5642e862ef49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ngxtop-ce
+ pkgdesc = Real-time metrics for nginx server
+ pkgver = 0.0.3a6
+ pkgrel = 1
+ url = https://github.com/ngxtop/ngxtop
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-docopt
+ depends = python-tabulate
+ depends = python-pyparsing
+ provides = ngxtop
+ conflicts = ngxtop
+ source = https://files.pythonhosted.org/packages/source/n/ngxtop-ce/ngxtop-ce-0.0.3a6.tar.gz
+ sha256sums = 0d0c7d99d2a542b8621d3f397e7b9870427f87402669eff3d8ef3ab61cded9fa
+
+pkgname = ngxtop-ce
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91f9421f1947
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Lex Black <autumn-wind@web.de>
+
+pkgname=ngxtop-ce
+pkgver=0.0.3a6
+pkgrel=1
+pkgdesc="Real-time metrics for nginx server"
+arch=('any')
+url="https://github.com/ngxtop/ngxtop"
+license=('MIT')
+depends=('python-docopt' 'python-tabulate' 'python-pyparsing')
+makedepends=('python-setuptools')
+conflicts=('ngxtop')
+provides=('ngxtop')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('0d0c7d99d2a542b8621d3f397e7b9870427f87402669eff3d8ef3ab61cded9fa')
+
+
+build () {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --optimize=1 --root="${pkgdir}" --skip-build
+}
+
+# vim:set et sw=2 ts=2 tw=79: