summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantinos Sideris2018-04-12 23:44:36 +0300
committerKonstantinos Sideris2018-04-12 23:44:36 +0300
commit73d4b0877bbbcc170a4cb6e7c75d88a839530fed (patch)
treea9ee68840b31b1d49161981c0e11ccb769c57d8f
parent9628c9f42008cf93feca2bb60e589820a40d3a28 (diff)
downloadaur-73d4b0877bbbcc170a4cb6e7c75d88a839530fed.tar.gz
Bump version to v0.3.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f4c18022ff5..e0930a06286f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nheko-git
pkgdesc = Desktop client for the Matrix protocol
- pkgver = 0.2.1.r520.d703377a
+ pkgver = 0.3.0.r520.d703377a
pkgrel = 1
url = https://github.com/mujx/nheko
arch = i686
@@ -14,6 +14,8 @@ pkgbase = nheko-git
depends = qt5-base
depends = lmdb
depends = qt5-multimedia
+ provides = nheko
+ conflicts = nheko
source = nheko-git::git://github.com/mujx/nheko.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6aa2efc0bfe7..d3dc93b42f35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Konstantinos Sideris <siderisk at auth dot gr>
pkgname=nheko-git
-pkgver=0.2.1.r520.d703377a
+pkgver=0.3.0.r571.e032f293
pkgrel=1
pkgdesc="Desktop client for the Matrix protocol"
arch=("i686" "x86_64")
@@ -12,6 +12,9 @@ license=("GPL3")
depends=("qt5-base" "lmdb" "qt5-multimedia")
makedepends=("git" "cmake" "gcc" "fontconfig" "qt5-tools")
+provides=("nheko")
+conflicts=("nheko")
+
source=($pkgname::git://github.com/mujx/nheko.git)
md5sums=("SKIP")
@@ -21,12 +24,12 @@ prepare() {
pkgver() {
cd "$pkgname"
- printf "0.2.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "0.3.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd "$pkgname"
- cmake -H. -Bbuild -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ cmake -H. -Bbuild -DCMAKE_BUILD_TYPE=Release
cmake --build build
}