summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Stammler2016-11-04 22:40:43 +0100
committerSebastian Stammler2016-11-04 22:52:04 +0100
commit10ab811a5429bcb772b214749b1808ac124490a8 (patch)
tree20b3ea714a6b3903487f3537b42e5b0980a5d54f
downloadaur-10ab811a5429bcb772b214749b1808ac124490a8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33117846b1fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nheqminer-cpu-git
+ pkgdesc = zcash equihash miner by NiceHash. Xenoncat CPU solver build.
+ pkgver = 0.4b.r1.ge2a73b4
+ pkgrel = 1
+ url = https://github.com/nicehash/nheqminer/
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = boost
+ optdepends = zcash: zcash node and tools
+ source = nheqminer-cpu-git::git+https://github.com/nicehash/nheqminer.git
+ md5sums = SKIP
+
+pkgname = nheqminer-cpu-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3a3466e268e8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+nheqminer-cpu-git
+/*.src.tar*
+/*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cc4d9d47c03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# NiceHash equihash miner. CPU xenocat solver build
+# Maintainer: Sebastian Stammler <echo c2ViQGhkZG4uc3BhY2UK|base64 -d>
+_pkgname=nheqminer-cpu
+pkgname=${_pkgname}-git
+pkgver=0.4b.r1.ge2a73b4
+pkgrel=1
+pkgdesc="zcash equihash miner by NiceHash. Xenoncat CPU solver build."
+arch=('x86_64')
+url="https://github.com/nicehash/nheqminer/"
+license=('MIT')
+depends=('boost')
+makedepends=('git')
+optdepends=('zcash: zcash node and tools')
+source=("${pkgname}::git+https://github.com/nicehash/nheqminer.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+_build_dir="Linux_cmake/nheqminer_cpu"
+build() {
+ cd "${pkgname}/cpu_xenoncat/Linux/asm/"
+ sh assemble.sh
+ cd "../../../${_build_dir}"
+ cmake .
+ make -j $(nproc)
+}
+
+package() {
+ cd "${pkgname}"
+ install -D -m755 "${_build_dir}/nheqminer_cpu" -t "${pkgdir}/usr/bin/"
+ install -D -m644 LICENSE_MIT -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}