summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Stammler2016-11-07 15:06:59 +0100
committerSebastian Stammler2016-11-07 15:06:59 +0100
commit91f51c59112e68fc2fd3298cb622d1824bf11e63 (patch)
treeb84663c0df5e334932f5f7d4f9793946b0c32b40
parent08c2286c80cc7883cbeb6bb2479f51dd8b63120c (diff)
downloadaur-91f51c59112e68fc2fd3298cb622d1824bf11e63.tar.gz
[cuda] Initial cuda package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0775897a5107..93f1a9618e63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
-pkgbase = nheqminer-cpu-git
- pkgdesc = zcash equihash miner by NiceHash. Xenoncat CPU solver build.
+pkgbase = nheqminer-cuda-git
+ pkgdesc = zcash equihash miner by NiceHash. Tromp GPU/CUDA solver build.
pkgver = 0.4b.r1.ge2a73b4
- pkgrel = 2
+ pkgrel = 1
url = https://github.com/nicehash/nheqminer/
arch = x86_64
license = MIT
makedepends = git
depends = boost
+ depends = cuda
optdepends = zcash: zcash node and tools
- source = nheqminer-cpu-git::git+https://github.com/nicehash/nheqminer.git
+ source = nheqminer-cuda-git::git+https://github.com/nicehash/nheqminer.git
md5sums = SKIP
-pkgname = nheqminer-cpu-git
+pkgname = nheqminer-cuda-git
diff --git a/PKGBUILD b/PKGBUILD
index 377e2a2ea297..298053bd2657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# NiceHash equihash miner. CPU xenocat solver build
+# NiceHash equihash miner. Tromp GPU/CUDAsolver build
# Maintainer: Sebastian Stammler <echo c2ViQGhkZG4uc3BhY2UK|base64 -d>
-_pkgname=nheqminer-cpu
+_pkgname=nheqminer-cuda
pkgname=${_pkgname}-git
pkgver=0.4b.r1.ge2a73b4
-pkgrel=2
-pkgdesc="zcash equihash miner by NiceHash. Xenoncat CPU solver build."
+pkgrel=1
+pkgdesc="zcash equihash miner by NiceHash. Tromp GPU/CUDA solver build."
arch=('x86_64')
url="https://github.com/nicehash/nheqminer/"
license=('MIT')
-depends=('boost')
+depends=('boost' 'cuda')
makedepends=('git')
optdepends=('zcash: zcash node and tools')
source=("${pkgname}::git+https://github.com/nicehash/nheqminer.git")
@@ -22,11 +22,15 @@ pkgver() {
_binary="nheqminer_cuda_tromp"
_build_dir="Linux_cmake/${_binary}"
build() {
- cd "${pkgname}/cpu_xenoncat/Linux/asm/"
- sh assemble.sh
- cd "../../../${_build_dir}"
+ cd "${pkgname}/${_build_dir}"
# Since we don't use make install, skip setting RPATH in the binary
- cmake -DCMAKE_SKIP_BUILD_RPATH=true .
+ # and use gcc-5 for compilation. Add COMPUTE=30 etc if you need to change
+ # nvidia compute version of your card(s)
+ cmake . -DCMAKE_SKIP_BUILD_RPATH=true \
+ -DCMAKE_C_COMPILER=/usr/bin/gcc-5 \
+ -DCMAKE_CXX_COMPILER=/usr/bin/g++-5 \
+ -DCMAKE_RANLIB=/usr/bin/gcc-ranlib-5 \
+ -DCMAKE_AR=/usr/bin/gcc-ar-5
make -j $(nproc)
}