summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Stammler2017-01-18 13:09:25 +0100
committerSebastian Stammler2017-01-18 13:09:25 +0100
commit9f9162f9575bcd3759116c9481a8effaeaaa0fde (patch)
tree043797fd667e0c8acfcb97711fbff0ccb7a395d4
parent53e294d3a2c802cedfaf5b5ca1ed69747491b736 (diff)
parentb97ee45c716e38d9e062242262b48d3b8df7dc63 (diff)
downloadaur-9f9162f9575bcd3759116c9481a8effaeaaa0fde.tar.gz
Change PKGBUILD to use new paths layout
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80dbec8bde5e..0dc2aabe9fbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nheqminer-cuda-git
- pkgdesc = zcash equihash miner by NiceHash. Tromp GPU/CUDA solver build.
- pkgver = 0.4b.r0.geb37570
+ pkgdesc = zcash equihash miner by NiceHash. Djezo GPU/CUDA solver build.
+ pkgver = 0.5c.r1.gb9900ff
pkgrel = 1
url = https://github.com/nicehash/nheqminer/
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = nheqminer-cuda-git
depends = boost
depends = cuda
optdepends = zcash: zcash node and tools
- source = nheqminer-cuda-git::git+https://github.com/nicehash/nheqminer.git#branch=Linux
+ source = nheqminer-cuda-git::git+https://github.com/nicehash/nheqminer.git
md5sums = SKIP
pkgname = nheqminer-cuda-git
diff --git a/PKGBUILD b/PKGBUILD
index afbe79ff34a2..922adb18672a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# NiceHash equihash miner. Tromp GPU/CUDAsolver build
# Maintainer: Sebastian Stammler <echo c2ViQGhkZG4uc3BhY2UK|base64 -d>
-_pkgname=nheqminer-cuda
-pkgname=${_pkgname}-git
-pkgver=0.4b.r0.geb37570
+_flavour="cuda"
+pkgname="nheqminer-${_flavour}-git"
+pkgver=0.5c.r1.gb9900ff
pkgrel=1
-pkgdesc="zcash equihash miner by NiceHash. Tromp GPU/CUDA solver build."
+pkgdesc="zcash equihash miner by NiceHash. Djezo GPU/CUDA solver build."
arch=('x86_64')
url="https://github.com/nicehash/nheqminer/"
license=('MIT')
depends=('boost' 'cuda')
makedepends=('git' 'cmake')
optdepends=('zcash: zcash node and tools')
-source=("${pkgname}::git+https://github.com/nicehash/nheqminer.git#branch=Linux")
+source=("${pkgname}::git+https://github.com/nicehash/nheqminer.git")
md5sums=('SKIP')
pkgver() {
@@ -19,10 +19,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-_binary="nheqminer_cuda_tromp"
-_build_dir="Linux_cmake/${_binary}"
+_build_dir="build_${_flavour}"
build() {
- cd "${pkgname}/${_build_dir}"
+ # Fix hardcoded sources path
+ sed -ie 's#\.\.\/nheqminer#\.\.\/'"${pkgname}"'#g' "${pkgname}/CMakeLists.txt"
+ mkdir -p ${_build_dir}
+ cd ${_build_dir}
# Since we don't use make install, skip setting RPATH in the binary
# and use gcc-5 for compilation. Add COMPUTE=30 (or similar) right after
# 'cmake' if you need to change nvidia compute version of your card(s)
@@ -32,12 +34,14 @@ build() {
-DCMAKE_CXX_COMPILER=/usr/bin/g++-5 \
-DCMAKE_RANLIB=/usr/bin/gcc-ranlib-5 \
-DCMAKE_AR=/usr/bin/gcc-ar-5 \
- .
+ -DUSE_CUDA_DJEZO=true \
+ -DUSE_CPU_XENONCAT=false \
+ ../${pkgname}
+
make -j $(nproc)
}
package() {
- cd "${pkgname}"
- install -D -m755 "${_build_dir}/${_binary}" -t "${pkgdir}/usr/bin/"
- install -D -m644 LICENSE_MIT -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -D -m755 "${_build_dir}/nheqminer" -t "${pkgdir}/usr/bin/nheqminer_${_flavour}"
+ install -D -m644 "${pkgname}/LICENSE_MIT" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}