summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Stammler2017-01-18 11:49:51 +0100
committerSebastian Stammler2017-01-18 11:49:51 +0100
commitb97ee45c716e38d9e062242262b48d3b8df7dc63 (patch)
tree6ecdbebc68b1e229c132e56d350b9c68e5877b0c
parentf5b8d850316746d8671187226579a2ed2ce55d7a (diff)
downloadaur-b97ee45c716e38d9e062242262b48d3b8df7dc63.tar.gz
Change PKGBUILD to use new paths layout
bumb version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e8766313e5a..cc3630f89e8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nheqminer-cpu-git
pkgdesc = zcash equihash miner by NiceHash. Xenoncat CPU solver build.
- pkgver = 0.4b.r2.g519cdf0
+ pkgver = 0.5c.r1.gb9900ff
pkgrel = 1
url = https://github.com/nicehash/nheqminer/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d834dc8e2bc6..82606aa89851 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# NiceHash equihash miner. CPU xenocat solver build
# Maintainer: Sebastian Stammler <echo c2ViQGhkZG4uc3BhY2UK|base64 -d>
-_pkgname=nheqminer-cpu
-pkgname=${_pkgname}-git
-pkgver=0.4b.r2.g519cdf0
+_flavour="cpu"
+pkgname="nheqminer-${_flavour}-git"
+pkgver=0.5c.r1.gb9900ff
pkgrel=1
pkgdesc="zcash equihash miner by NiceHash. Xenoncat CPU solver build."
arch=('x86_64')
@@ -19,19 +19,27 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-_binary="nheqminer_cpu"
-_build_dir="Linux_cmake/${_binary}"
+_build_dir="build_${_flavour}"
build() {
- cd "${pkgname}/cpu_xenoncat/Linux/asm/"
+ cd "${pkgname}/cpu_xenoncat/asm_linux/"
+ chmod a+x fasm # Until my PR #226 is merged...
sh assemble.sh
- cd "../../../${_build_dir}"
+ cd "../../"
+ # Fix hardcoded sources path
+ sed -ie 's#\.\.\/nheqminer#\.\.\/'"${pkgname}"'#g' CMakeLists.txt
+ cd ..
+ mkdir -p ${_build_dir}
+ cd ${_build_dir}
# Since we don't use make install, skip setting RPATH in the binary
- cmake -DCMAKE_SKIP_BUILD_RPATH=true .
+ cmake -DCMAKE_SKIP_BUILD_RPATH=true \
+ -DUSE_CUDA_DJEZO=false \
+ ../${pkgname}
+
make -j $(nproc)
}
package() {
- cd "${pkgname}"
- install -D -m755 "${_build_dir}/${_binary}" -t "${pkgdir}/usr/bin/"
- install -D -m644 LICENSE_MIT -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ #cd "${pkgname}"
+ install -D -m755 "${_build_dir}/nheqminer" -t "${pkgdir}/usr/bin/nheqminer_${_flavour}"
+ install -D -m644 "${pkgname}/LICENSE_MIT" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}