summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-06-06 01:26:45 +0300
committerDimitris Kiziridis2020-06-06 01:26:45 +0300
commit9addc05f58582d6f7c5f19623bb97859f33ee946 (patch)
treee0d4e6cb1c1778c81c5a4009ef09ff8a7fcaabc9
downloadaur-9addc05f58582d6f7c5f19623bb97859f33ee946.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..343c4d2e25cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ni-translate-git
+ pkgdesc = A translator for Linux, running at the background which wakes up with the translation of the last selected text after tapping the specific key twice
+ pkgver = r71.4744cf1
+ pkgrel = 1
+ url = https://github.com/yasirtug/ni-translate
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-base
+ depends = qt5-base
+ provides = ni-translate
+ source = ni-translate::git+https://github.com/yasirtug/ni-translate
+ sha256sums = SKIP
+
+pkgname = ni-translate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e954b12496e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=ni-translate-git
+pkgver=r71.4744cf1
+pkgrel=1
+pkgdesc='A translator for Linux, running at the background which wakes up with the translation of the last selected text after tapping the specific key twice'
+arch=('i686' 'x86_64')
+url='https://github.com/yasirtug/ni-translate'
+license=('GPL3')
+provides=('ni-translate')
+depends=('qt5-base')
+makedepends=('qt5-base')
+source=("${pkgname%-git}::git+https://github.com/yasirtug/ni-translate")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ni-translate
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ni-translate
+ qmake -spec linux-g++
+ make
+}
+
+package() {
+ cd ni-translate
+ gendesk -f -n --pkgname "${pkgname%-git}" \
+ --pkgdesc "$pkgdesc" \
+ --name "ni-translate" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname%-git}" \
+ --categories 'Utility' \
+ --icon "${pkgname%-git}"
+ install -Dm644 ni-translate.desktop -t "${pkgdir}/usr/share/applications"
+ install -Dm755 ni-translate -t "${pkgdir}/usr/bin"
+ install -Dm644 icon.png "${pkgdir}/usr/share/pixmaps/ni-translate.png"
+} \ No newline at end of file