summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxdrie2021-01-12 16:49:45 -0800
committerxdrie2021-01-12 16:49:45 -0800
commitce70f406350abc27b7abe320160014e91612e5b0 (patch)
tree9244abb992258722f29366af5b048cfce41e3424
parent56f39086ec7edabdbc040f8c1b94c8aa1f8be8cc (diff)
downloadaur-ce70f406350abc27b7abe320160014e91612e5b0.tar.gz
update stuff
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d93565740be1..e4d50cf04b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: xhyinne <xhyi AT gmx DOT us>
pkgname=niacop-git
-pkgver=v0.7.0.r0.ge5f3677
+pkgver=0.7.0.r28.g120697c
pkgrel=1
pkgdesc="Cross platform self-tracker tool"
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
depends=('xprintidle' 'xorg-xprop' 'xdotool' 'xorg-xinput' 'xorg-xmodmap')
makedepends=('git' 'dotnet-sdk>=5.0.1.sdk101')
optdepends=()
-source=("$pkgname::git+https://github.com/xdrie/niacop.git")
+source=("$pkgname::git+https://github.com/xdrie/niacop.git#branch=master")
sha256sums=('SKIP')
_basename=${pkgname%-git}
@@ -23,18 +23,18 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
rm -rf compiled
+
env DOTNET_CLI_TELEMETRY_OPTOUT=1 dotnet publish src/niacop/Nia/Nia.csproj \
--configuration Release \
--runtime $(dotnet --info | grep 'RID' | cut -d ':' -f 2 | tr -d '[:space:]') \
- /p:UseCoreRT=1 \
--output compiled
}
package() {
# copy built stuff
- cd "$srcdir/$pkgname/compiled"
- find . -type f -exec \
- install -Dm755 "{}" "$pkgdir/opt/${_basename}/{}" \;
+ # cd "$srcdir/$pkgname/compiled"
+ mkdir -p "$pkgdir/opt/${_basename}"
+ cp -dr --no-preserve='ownership' "$srcdir/$pkgname/compiled/." "$pkgdir/opt/${_basename}/"
# link main binary
mkdir -p "$pkgdir/usr/bin"