summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-01-01 08:16:00 -0700
committerMark Wagie2023-01-01 08:16:00 -0700
commit120629381f0f55d5ae69e3edf5c457686f4d114b (patch)
tree9962f6ae4b74d8a0d3392ed38a58f38e76fc3c90
parent62192235e2e655bfc57b3050553af0d42313c557 (diff)
downloadaur-120629381f0f55d5ae69e3edf5c457686f4d114b.tar.gz
drop gspell, install locale
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d253903947f..a7d8e1f38904 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nicotine-plus-git
pkgdesc = A graphical client for the SoulSeek peer-to-peer system
- pkgver = 3.3.0.dev4.r8514.577411e21
+ pkgver = 3.3.0.dev4.r8612.420bfa71c
pkgrel = 1
url = https://nicotine-plus.org
arch = any
@@ -17,7 +17,6 @@ pkgbase = nicotine-plus-git
optdepends = gtk4: default Gtk version
optdepends = libadwaita: used with gtk4 if available
optdepends = gtk3: fallback if gtk4 is not installed
- optdepends = gspell: for spell checking in chat (Gtk 3 only)
optdepends = libayatana-appindicator: tray icon (Gtk 3 only
provides = nicotine-plus
provides = nicotine+
diff --git a/PKGBUILD b/PKGBUILD
index cfef453fa2e7..ba8ab0652dc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: x-demon
pkgname=nicotine-plus-git
_appdata_id=org.nicotine_plus.Nicotine
-pkgver=3.3.0.dev4.r8514.577411e21
+pkgver=3.3.0.dev4.r8612.420bfa71c
pkgrel=1
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
@@ -15,7 +15,6 @@ makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python
optdepends=('gtk4: default Gtk version'
'libadwaita: used with gtk4 if available'
'gtk3: fallback if gtk4 is not installed'
- 'gspell: for spell checking in chat (Gtk 3 only)'
'libayatana-appindicator: tray icon (Gtk 3 only')
checkdepends=('appstream-glib' 'desktop-file-utils' 'python-pytest-xvfb')
provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
@@ -54,4 +53,12 @@ check() {
package() {
cd "$srcdir/${pkgname%-git}"
python -m installer --destdir="$pkgdir" dist/*.whl
+
+ cd po
+ for lang in $(ls *.po); do
+ echo "lang: ${lang}"
+ lang=${lang::-3}
+ install -d "$pkgdir/usr/share/locale/${lang//_/-}/LC_MESSAGES"
+ msgfmt -c -o "$pkgdir/usr/share/locale/${lang//_/-}/LC_MESSAGES/nicotine.mo" "${lang}.po"
+ done
}