summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-06-14 13:32:18 -0600
committerMark Wagie2021-06-14 13:32:18 -0600
commit1680b9516319811d7b47391c1145ee6b189c01d3 (patch)
tree81b736aa46145a1ca9445a13c107777e1f176e9e
parentdb8295ba0f6dc495f956e0ab7a07b037645fcb18 (diff)
downloadaur-1680b9516319811d7b47391c1145ee6b189c01d3.tar.gz
disable tests
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e489ffc10032..29b73c409ff8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = nicotine-plus-git
pkgdesc = A graphical client for the SoulSeek peer-to-peer system
- pkgver = 3.0.7.dev1.r4749.c646b3ca
+ pkgver = 3.1.0.dev1.r5003.0998e180
pkgrel = 1
url = https://nicotine-plus.github.io/nicotine-plus
arch = any
license = GPL3
- checkdepends = python-pytest
- checkdepends = xorg-server-xvfb
makedepends = git
depends = python-gobject
depends = gtk3
@@ -22,4 +20,3 @@ pkgbase = nicotine-plus-git
sha256sums = SKIP
pkgname = nicotine-plus-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 41b3d1040eec..f99a5ddd4889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: x-demon
pkgname=nicotine-plus-git
-pkgver=3.0.7.dev1.r4749.c646b3ca
+pkgver=3.1.0.dev1.r5003.0998e180
pkgrel=1
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
@@ -13,7 +13,7 @@ depends=('python-gobject' 'gtk3')
makedepends=('git')
optdepends=('gspell: for spell checking in chat'
'libappindicator-gtk3: for tray icon')
-checkdepends=('python-pytest' 'xorg-server-xvfb')
+#checkdepends=('xorg-server-xvfb')
provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
conflicts=("${pkgname%-git}" 'nicotine+' 'nicotine')
source=('git+https://github.com/Nicotine-Plus/nicotine-plus.git')
@@ -30,15 +30,15 @@ build() {
python setup.py build
}
-check() {
- cd "$srcdir/${pkgname%-git}"
+#check() {
+# cd "$srcdir/${pkgname%-git}"
# Basic sanity check
- ./nicotine --version | grep Nicotine+
+# ./nicotine --version | grep Nicotine+
# Perform integration and unit tests
- xvfb-run pytest
-}
+# xvfb-run python -m unittest
+#}
package() {
cd "$srcdir/${pkgname%-git}"