summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-06-03 18:23:10 -0600
committerMark Wagie2020-06-03 18:23:10 -0600
commit3a4b9378f47ba51c0097891f95ad76e1abf19aef (patch)
treeec525b9f9184512a7e8b8287bb9497443ae1fa0b
parente27e12c2ef49e1d95c105cf24983a590a8ec673e (diff)
downloadaur-3a4b9378f47ba51c0097891f95ad76e1abf19aef.tar.gz
info about tests
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a40c6b64ca4..6643c2584e81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nicotine-plus-git
pkgdesc = A graphical client for the SoulSeek peer-to-peer system
- pkgver = 1.4.3.2.r2476.e37a65c7
+ pkgver = 1.4.3.2.r2493.c334fe4c
pkgrel = 1
url = http://nicotine-plus.org
arch = any
@@ -19,9 +19,9 @@ pkgbase = nicotine-plus-git
optdepends = python-miniupnpc: Python bindings for miniupnpc
optdepends = python-geoip: for geo-blocker
optdepends = python-feedparser: for Reddit plugin
- optdepends = gspell: for spell checking support
- optdepends = nuspell: for spell checking support
- optdepends = libappindicator-gtk3: for tray icon support
+ optdepends = gspell: for spell checking in chat
+ optdepends = nuspell: for spell checking in chat
+ optdepends = libappindicator-gtk3: for tray icon
optdepends = gsound: for sound effects
provides = nicotine-plus
provides = nicotine+
diff --git a/PKGBUILD b/PKGBUILD
index 7937804a533e..face235d00ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: x-demon
pkgname=nicotine-plus-git
-pkgver=1.4.3.2.r2476.e37a65c7
+pkgver=1.4.3.2.r2493.c334fe4c
pkgrel=1
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
@@ -16,9 +16,9 @@ optdepends=('miniupnpc: UPnP support'
'python-miniupnpc: Python bindings for miniupnpc'
'python-geoip: for geo-blocker'
'python-feedparser: for Reddit plugin'
- 'gspell: for spell checking support'
- 'nuspell: for spell checking support'
- 'libappindicator-gtk3: for tray icon support'
+ 'gspell: for spell checking in chat'
+ 'nuspell: for spell checking in chat'
+ 'libappindicator-gtk3: for tray icon'
'gsound: for sound effects')
checkdepends=('python-pytest')
#checkdepends=('python-pytest-xvfb' 'robotframework' 'miniupnpc')
@@ -40,9 +40,17 @@ build() {
check() {
cd "$srcdir/${pkgname%-git}"
-# nicotine --version | grep Nicotine+
+
+ # Basic sanity check
+ ./nicotine --version | grep Nicotine+
+
+ # Perform local in-tree unit tests
pytest test/unit
-# xvfb-run robot test/integration/nicotine.robot
+
+ # Requires Nicotine+ to be installed
+
+ # Run the GUI inside of a dummy frame buffer
+# xvfb-run robot test/integration/nicotine.robot
}
package() {