summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-04-27 19:22:23 -0600
committerMark Wagie2020-04-27 19:22:23 -0600
commit51c9efa1510c0dcabe873094f7311c0b61563204 (patch)
treed18da7ff1f155c8a40591a67257a0dc441a6d929
parentc6bf8ab5ad94725974508d2ab92bac5063328e88 (diff)
downloadaur-51c9efa1510c0dcabe873094f7311c0b61563204.tar.gz
PKGBUILD improvements
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15036b7f5b9a..ac6aed29562a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = nicotine-plus-git
- pkgdesc = A fork of Nicotine, a graphical client for Soulseek.
- pkgver = 1.4.1.r17.g8b2c199
- pkgrel = 2
- url = http://nicotine-plus.org/
+ pkgdesc = A graphical client for the SoulSeek peer-to-peer system
+ pkgver = 1.4.1.r33.g7652f169
+ pkgrel = 1
+ url = http://nicotine-plus.org
arch = any
license = GPL3
makedepends = git
makedepends = python2
depends = pygtk
- depends = gtk2
depends = python2-mutagen
optdepends = miniupnpc: UPnP support
optdepends = python2-geoip: for geo-blocker
optdepends = python2-notify: for notifications
+ provides = nicotine-plus
+ provides = nicotine+
+ provides = nicotine
+ conflicts = nicotine-plus
+ conflicts = nicotine+
+ conflicts = nicotine
source = git+https://github.com/Nicotine-Plus/nicotine-plus.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 878ed0fac112..f0758408f508 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
-# Maintainer: Rafael Cavalcanti <rccavalcanti at gmail dot com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Rafael Cavalcanti <rccavalcanti at gmail dot com>
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: x-demon
pkgname=nicotine-plus-git
-_gitname=nicotine-plus
-pkgver=1.4.1.r17.g8b2c199
-pkgrel=2
-pkgdesc="A fork of Nicotine, a graphical client for Soulseek."
+pkgver=1.4.1.r33.g7652f169
+pkgrel=1
+pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
-url="http://nicotine-plus.org/"
+url="http://nicotine-plus.org"
license=('GPL3')
-depends=('pygtk' 'gtk2' 'python2-mutagen')
+depends=('pygtk' 'python2-mutagen')
makedepends=('git' 'python2')
optdepends=('miniupnpc: UPnP support'
- 'python2-geoip: for geo-blocker'
- 'python2-notify: for notifications')
-source=(git+https://github.com/Nicotine-Plus/${_gitname}.git)
+ 'python2-geoip: for geo-blocker'
+ 'python2-notify: for notifications')
+provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
+conflicts=("${pkgname%-git}" 'nicotine+' 'nicotine')
+source=("git+https://github.com/Nicotine-Plus/nicotine-plus.git")
sha512sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
- git describe --long --tags | sed 's/-/.r/;s/-/./'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_gitname}"
+ cd "$srcdir/${pkgname%-git}"
python2 setup.py build
}
package() {
- cd "${srcdir}/${_gitname}"
+ cd "$srcdir/${pkgname%-git}"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
-