summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:31:59 +0200
committerJorge Barroso2015-06-15 21:31:59 +0200
commitbaa08fe0ec8c293cd2488b308ff8d149954db6b8 (patch)
tree725de776e287436cdfcf0401e100073fab2b2b8a
downloadaur-baa08fe0ec8c293cd2488b308ff8d149954db6b8.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5f1f99a57e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = nicotine-plus-git
+ pkgdesc = A fork of nicotine, a Soulseek music-sharing client written in python. Gitversion.
+ pkgver = 037e16c
+ pkgrel = 3
+ url = http://nicotine-plus.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = python2
+ depends = pygtk
+ depends = gtk2
+ optdepends = mutagen: To improve metadata
+ optdepends = python-sexy: To enable spell checking
+ optdepends = python-geoip: To enable Geographical blocker
+ conflicts = nicotine
+ conflicts = nicotine-plus
+ replaces = nicotine
+ replaces = nicotine-plus
+ source = git+https://github.com/eLvErDe/nicotine-plus.git
+ sha512sums = SKIP
+
+pkgname = nicotine-plus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40c4d55f5132
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+#! /bin/bash
+# Contributor: x-demon
+# Maintainer : Jorge Barroso <jorge.barroso.11 at gmail dot com>
+
+pkgname=nicotine-plus-git
+pkgver=037e16c
+pkgrel=3
+pkgdesc="A fork of nicotine, a Soulseek music-sharing client written in python. Gitversion."
+arch=('i686' 'x86_64')
+url=("http://nicotine-plus.org")
+license=('GPL')
+depends=('pygtk' 'gtk2')
+makedepends=('git' 'python2')
+optdepends=('mutagen: To improve metadata'
+ 'python-sexy: To enable spell checking'
+ 'python-geoip: To enable Geographical blocker')
+conflicts=('nicotine' 'nicotine-plus')
+replaces=('nicotine' 'nicotine-plus')
+source=(git+https://github.com/eLvErDe/nicotine-plus.git)
+sha512sums=('SKIP')
+
+_gitname=nicotine-plus
+
+pkgver() {
+ cd ${srcdir}/$_gitname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+
+ python2 setup.py install --root=$srcdir/pkg
+}
+
+package(){
+ mv ${srcdir}/pkg/* ${pkgdir}
+}