summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-12-13 17:56:51 -0700
committerMark Wagie2021-12-13 17:56:51 -0700
commitc25bb92aceca8166f3f47364dd3519989a9c73ac (patch)
tree0cbcbd7e71eb2cd7bc202f649d7363dbbf0d5bf4
parent00a8db3e1226c65b14667f271adb423ced0b38a1 (diff)
downloadaur-c25bb92aceca8166f3f47364dd3519989a9c73ac.tar.gz
add Gtk 4 shortcut
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
-rw-r--r--org.nicotine_plus.Nicotine-gtk4.desktop65
4 files changed, 82 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b25049e53f5e..19b2db6d0011 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nicotine-plus-git
pkgdesc = A graphical client for the SoulSeek peer-to-peer system
- pkgver = 3.2.0.dev1.r5746.6bc97e2e
- pkgrel = 1
+ pkgver = 3.2.0rc2.r6472.c6fadb13
+ pkgrel = 2
url = https://nicotine-plus.github.io/nicotine-plus
arch = any
license = GPL3
@@ -17,6 +17,7 @@ pkgbase = nicotine-plus-git
optdepends = libappindicator-gtk3: option for tray icon
optdepends = libayatana-appindicator: option for tray icon
optdepends = gtk4: test the GTK4 version
+ optdepends = libadwaita: test the GTK4 version
provides = nicotine-plus
provides = nicotine+
provides = nicotine
@@ -24,6 +25,8 @@ pkgbase = nicotine-plus-git
conflicts = nicotine+
conflicts = nicotine
source = git+https://github.com/Nicotine-Plus/nicotine-plus.git
+ source = org.nicotine_plus.Nicotine-gtk4.desktop
sha256sums = SKIP
+ sha256sums = a9134a8afe1071f240e012105f721515cd5ad9ad538bb66a51937f06b2f04195
pkgname = nicotine-plus-git
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..d895518e783b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!org.nicotine_plus.Nicotine-gtk4.desktop
diff --git a/PKGBUILD b/PKGBUILD
index fc904ddc147d..0f0c9f9d12da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: x-demon
pkgname=nicotine-plus-git
-pkgver=3.2.0.dev1.r5746.6bc97e2e
-pkgrel=1
+pkgver=3.2.0rc2.r6472.c6fadb13
+pkgrel=2
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
url="https://nicotine-plus.github.io/nicotine-plus"
@@ -14,12 +14,15 @@ makedepends=('appstream' 'git' 'python-setuptools')
optdepends=('gspell: for spell checking in chat'
'libappindicator-gtk3: option for tray icon'
'libayatana-appindicator: option for tray icon'
- 'gtk4: test the GTK4 version')
+ 'gtk4: test the GTK4 version'
+ 'libadwaita: test the GTK4 version')
checkdepends=('appstream-glib' 'desktop-file-utils' 'python-pytest-xvfb')
provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
conflicts=("${pkgname%-git}" 'nicotine+' 'nicotine')
-source=('git+https://github.com/Nicotine-Plus/nicotine-plus.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/Nicotine-Plus/nicotine-plus.git'
+ 'org.nicotine_plus.Nicotine-gtk4.desktop')
+sha256sums=('SKIP'
+ 'a9134a8afe1071f240e012105f721515cd5ad9ad538bb66a51937f06b2f04195')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -54,6 +57,9 @@ package() {
cd "$srcdir/${pkgname%-git}"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/org.nicotine_plus.Nicotine-gtk4.desktop" -t \
+ "$pkgdir/usr/share/applications/"
+
# Remove duplicate GPL license
rm "$pkgdir/usr/share/doc/nicotine/COPYING"
}
diff --git a/org.nicotine_plus.Nicotine-gtk4.desktop b/org.nicotine_plus.Nicotine-gtk4.desktop
new file mode 100644
index 000000000000..400cf63697c5
--- /dev/null
+++ b/org.nicotine_plus.Nicotine-gtk4.desktop
@@ -0,0 +1,65 @@
+[Desktop Entry]
+Type=Application
+Version=1.1
+Name[cs]=Nicotine+ (Gtk 4)
+Name[da]=Nicotine+ (Gtk 4)
+Name[de]=Nicotine+ (Gtk 4)
+Name[eo]=Nicotine+ (Gtk 4)
+Name[es]=Nicotine+ (Gtk 4)
+Name[eu]=Nicotine+ (Gtk 4)
+Name[fi]=Nicotine+ (Gtk 4)
+Name[fr]=Nicotine+ (Gtk 4)
+Name[hu]=Nicotine+ (Gtk 4)
+Name[it]=Nicotine+ (Gtk 4)
+Name[nb_NO]=Nicotine+ (Gtk 4)
+Name[nl]=Nicotine+ (Gtk 4)
+Name[pl]=Nicotine+ (Gtk 4)
+Name[pt_BR]=Nicotine+ (Gtk 4)
+Name[ru]=Nicotine+ (Gtk 4)
+Name[sk]=Nicotine+ (Gtk 4)
+Name[tr]=Nicotine+ (Gtk 4)
+Name=Nicotine+ (Gtk 4)
+GenericName[cs]=Soulseek Klient
+GenericName[de]=Soulseek-Client
+GenericName[es]=Cliente de Soulseek
+GenericName[fr]=Client Soulseek
+GenericName[it]=Client per Soulseek
+GenericName[nb_NO]=Soulseek-klient
+GenericName[nl]=Soulseek cliënt
+GenericName[pl]=Klient Soulseek
+GenericName[pt_BR]=Cliente Soulseek
+GenericName[ru]=Клиент Soulseek
+GenericName[tr]=Soulseek İstemcisi
+GenericName=Soulseek Client
+Comment[cs]=Grafický klient pro Soulseek P2P síť
+Comment[de]=Grafischer Client für das Soulseek Peer-to-Peer-Netzwerk
+Comment[es]=Cliente gráfico para la red P2P Soulseek
+Comment[fr]=Client graphique pour le réseau P2P Soulseek
+Comment[it]=Client grafico per la rete peer-to-peer Soulseek
+Comment[nb_NO]=Grafisk klient for Soulseek-likemannsnettverket
+Comment[nl]=Grafische client voor het Soulseek peer-to-peer-netwerk
+Comment[pl]=Graficzny klient sieci P2P Soulseek
+Comment[pt_BR]=Cliente gráfico para a rede peer-to-peer Soulseek
+Comment[ru]=Графический клиент для одноранговой сети Soulseek
+Comment[sv]=Grafisk klient för peer-to-peer-nätverket Soulseek
+Comment[tr]=Soulseek eşler arası ağı için grafiksel istemci
+Comment=Graphical client for the Soulseek peer-to-peer network
+Icon=org.nicotine_plus.Nicotine
+Exec=env NICOTINE_GTK_VERSION=4 NICOTINE_LIBADWAITA=1 nicotine
+Terminal=false
+Categories=Network;FileTransfer;P2P;GTK;
+Keywords[cs]=Soulseek;Nicotine;sdílení;hudba;P2P;peer-to-peer;GTK;
+Keywords[de]=Soulseek;Nicotine;Austausch;Musik;P2P;Peer-to-Peer;GTK;
+Keywords[es]=Soulseek;Nicotine;compartir;música;P2P;para a par;GTK;
+Keywords[fr]=Soulseek ;Nicotine ;partage ;musique ;P2P ; pair-à-pair ;GTK ;
+Keywords[it]=Soulseek,Nicotine,condivisione;musica;P2P;peer-to-peer;GTK;
+Keywords[nb_NO]=Soulseek;Nicotine;deling;musikk;P2P;likemannsnettverk;GTK;
+Keywords[nl]=Soulseek;Nicotine;delen;muziek;P2P;peer-naar-peer;GTK;
+Keywords[pl]=Soulseek;Nicotine;sharing;music;P2P;peer-to-peer;GTK;
+Keywords[pt_BR]=Soulseek;Nicotine;compartilhamento;música; P2P;peer-to-peer;GTK;
+Keywords[ru]=Soulseek;Nicotine;обмен;музыка;P2P;одноранговая сеть;GTK;
+Keywords[tr]=Soulseek;Nicotine;sharing;music;P2P;peer-to-peer;GTK;paylaşım;müzik;eşler-arası;
+Keywords=Soulseek;Nicotine;sharing;music;P2P;peer-to-peer;GTK;
+StartupNotify=true
+X-GNOME-UsesNotifications=true
+