summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-05-09 12:59:30 -0600
committerMark Wagie2021-05-09 12:59:30 -0600
commitdb8295ba0f6dc495f956e0ab7a07b037645fcb18 (patch)
treefb43a106994ebb0eedd19ea52e000fae7b5ebc84
parent31c4a7f2c0decdb99e1230915278fd5d606d3f0c (diff)
downloadaur-db8295ba0f6dc495f956e0ab7a07b037645fcb18.tar.gz
adjust pkgver(), perform integration and unit tests
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8369c306fb43..e489ffc10032 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = nicotine-plus-git
pkgdesc = A graphical client for the SoulSeek peer-to-peer system
- pkgver = 2.3.0.dev1.r4051.e99823dc
+ pkgver = 3.0.7.dev1.r4749.c646b3ca
pkgrel = 1
url = https://nicotine-plus.github.io/nicotine-plus
arch = any
license = GPL3
checkdepends = python-pytest
+ checkdepends = xorg-server-xvfb
makedepends = git
depends = python-gobject
depends = gtk3
diff --git a/PKGBUILD b/PKGBUILD
index a794fd273b31..41b3d1040eec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: x-demon
pkgname=nicotine-plus-git
-pkgver=2.3.0.dev1.r4051.e99823dc
+pkgver=3.0.7.dev1.r4749.c646b3ca
pkgrel=1
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
@@ -13,7 +13,7 @@ depends=('python-gobject' 'gtk3')
makedepends=('git')
optdepends=('gspell: for spell checking in chat'
'libappindicator-gtk3: for tray icon')
-checkdepends=('python-pytest')
+checkdepends=('python-pytest' 'xorg-server-xvfb')
provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
conflicts=("${pkgname%-git}" 'nicotine+' 'nicotine')
source=('git+https://github.com/Nicotine-Plus/nicotine-plus.git')
@@ -21,8 +21,8 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- printf "%s.r%s.%s" "$(head -n 1 debian/changelog | cut -d'(' -f 2 | cut -d')' -f 1 | \
- sed 's/-/./')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.r%s.%s" "$(python setup.py --version)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
@@ -36,8 +36,8 @@ check() {
# Basic sanity check
./nicotine --version | grep Nicotine+
- # Perform local in-tree unit tests
- pytest test/unit
+ # Perform integration and unit tests
+ xvfb-run pytest
}
package() {