summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcs2017-12-25 21:06:42 +0100
committerMarcs2017-12-25 21:06:42 +0100
commit559869d259ff39cf55627347ba2d8a63d7cc6d5d (patch)
treed63f28a0afb47fcb610c262d417029d02c1d5254
parent958b08f2bb0cf98fa40be7d882717a99f5818108 (diff)
downloadaur-559869d259ff39cf55627347ba2d8a63d7cc6d5d.tar.gz
use system wide boot process and fix icon
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--nightcode.desktop2
3 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4038930dac9a..f58c1b28ad13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Dec 25 16:43:55 UTC 2017
+# Mon Dec 25 20:05:09 UTC 2017
pkgbase = nightcode
pkgdesc = An IDE that bundles a smart editor, the Leiningen and Boot build tools, and a home screen with quick access to the Clojure cheatsheet and REPL.
pkgver = 2.5.4
@@ -7,17 +7,15 @@ pkgbase = nightcode
url = https://sekao.net/nightcode/
arch = any
license = custom
+ makedepends = boot
depends = java-runtime>7
depends = java-openjfx
conflicts = nightcode-git
- noextract = boot.sh
noextract = nightcode.desktop
source = nightcode-2.5.4.tar.gz::https://github.com/oakes/Nightcode/archive/2.5.4.tar.gz
- source = https://github.com/boot-clj/boot-bin/releases/download/latest/boot.sh
source = nightcode.desktop
sha256sums = 26e86d224cc3cf17a85155f1c0f2d6d869524a7500c398bc32552c9bd33b3055
- sha256sums = 0ccd697f2027e7e1cd3be3d62721057cbc841585740d0aaa9fbb485d7b1f17c3
- sha256sums = 8fb613946bb9cb3dc636933ff2f0c7de8c61d2b43e49b9d6baf380b07377eaa1
+ sha256sums = aa94a3cf9028756b4bd6dbb6f9b27dc23f8aa4d29ca18507736561ef66fbd267
pkgname = nightcode
diff --git a/PKGBUILD b/PKGBUILD
index ffa278445d84..4394acaa0588 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,19 @@ pkgdesc="An IDE that bundles a smart editor, the Leiningen and Boot build tools,
arch=('any')
url="https://sekao.net/nightcode/"
license=('custom')
+makedepends=('boot')
depends=('java-runtime>7' 'java-openjfx')
conflicts=('nightcode-git')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/oakes/Nightcode/archive/${pkgver}.tar.gz"
- "https://github.com/boot-clj/boot-bin/releases/download/latest/boot.sh"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/oakes/${_name}/archive/${pkgver}.tar.gz"
"nightcode.desktop")
sha256sums=('26e86d224cc3cf17a85155f1c0f2d6d869524a7500c398bc32552c9bd33b3055'
- '0ccd697f2027e7e1cd3be3d62721057cbc841585740d0aaa9fbb485d7b1f17c3'
- '8fb613946bb9cb3dc636933ff2f0c7de8c61d2b43e49b9d6baf380b07377eaa1')
-noextract=('boot.sh'
- 'nightcode.desktop')
+ 'aa94a3cf9028756b4bd6dbb6f9b27dc23f8aa4d29ca18507736561ef66fbd267')
+noextract=('nightcode.desktop')
build() {
cd "${_name}-${pkgver}"
msg2 "Building nightcode..."
- bash ${srcdir}/boot.sh build
+ boot build
}
package() {
@@ -42,4 +40,5 @@ package() {
#icon
install -Dm644 ${srcdir}/nightcode.desktop ${pkgdir}/usr/share/applications/nightcode.desktop
+ install -Dm644 ${srcdir}/${_name}-${pkgver}/package/linux/Nightcode.png ${pkgdir}/usr/share/nightcode/Nightcode.png
}
diff --git a/nightcode.desktop b/nightcode.desktop
index b76447cfb5b9..134edcdff171 100644
--- a/nightcode.desktop
+++ b/nightcode.desktop
@@ -2,7 +2,7 @@
Name=Nightcode
Comment=A handy tool for your Clojure adventures
Type=Application
-Icon=nightcode
+Icon=/usr/share/nightcode/Nightcode.png
Exec=nightcode
Categories=Utility;TextEditor;Development
Terminal=false