summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Parnell2016-06-18 23:15:26 -0500
committerMatt Parnell2016-06-18 23:15:26 -0500
commit2b34bc2ccebf467749081bf0c3c8c32b01790300 (patch)
tree140cc0dac3041964317d230bcbc0abf6c63b2e25
parentb12735c6461f58006d9b63dead5cb8ced9c3b6cc (diff)
downloadaur-2b34bc2ccebf467749081bf0c3c8c32b01790300.tar.gz
we can once more build using no binaries
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD64
2 files changed, 58 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c81b2f0b3ed2..6fc5a0e38df1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Fri Jun 17 06:02:57 UTC 2016
+# Sun Jun 19 04:15:23 UTC 2016
pkgbase = nightingale-git
- pkgdesc = Open source fork of the Songbird Media Player. Uses prebuilt xulrunner and sqlite.
+ pkgdesc = No binaries used. Open source fork of the Songbird Media Player with updates and fixes.
pkgver = 78bd501
pkgrel = 1
url = http://getnightingale.com/
@@ -46,10 +46,10 @@ pkgbase = nightingale-git
provides = nightingale
conflicts = nightingale
source = nightingale-hacking::git://github.com/nightingale-media-player/nightingale-hacking.git#branch=gstreamer-1.0
- source = https://bitbucket.org/nightingale-media-player/nightingale-deps/downloads/linux--1.12-20130316-release-final.tar.lzma
+ source = nightingale-deps::git://github.com/nightingale-media-player/nightingale-deps.git#branch=xul-192-new
source = Nightingale.desktop
md5sums = SKIP
- md5sums = a9b47ef0b21106f6b51231046e1758d1
+ md5sums = SKIP
md5sums = 7741cc247648e95dd9dad8c953616757
pkgname = nightingale-git
diff --git a/PKGBUILD b/PKGBUILD
index 7aece25b6499..dc1ba9646ae8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname="nightingale-git"
pkgver=78bd501
pkgrel=1
-pkgdesc="Open source fork of the Songbird Media Player. Uses prebuilt xulrunner and sqlite."
+pkgdesc="No binaries used. Open source fork of the Songbird Media Player with updates and fixes."
arch=('i686' 'x86_64')
url="http://getnightingale.com/"
license=('GPL2' 'MPL' 'BSD')
@@ -16,10 +16,10 @@ conflicts=('nightingale')
provides=('nightingale')
install="nightingale.install"
source=("nightingale-hacking::git://github.com/nightingale-media-player/nightingale-hacking.git#branch=gstreamer-1.0"
- "https://bitbucket.org/nightingale-media-player/nightingale-deps/downloads/linux-${CARCH}-1.12-20130316-release-final.tar.lzma"
+ "nightingale-deps::git://github.com/nightingale-media-player/nightingale-deps.git#branch=xul-192-new"
"Nightingale.desktop")
md5sums=('SKIP'
- 'a9b47ef0b21106f6b51231046e1758d1'
+ 'SKIP'
'7741cc247648e95dd9dad8c953616757')
pkgver() {
@@ -33,19 +33,63 @@ prepare() {
echo 'ac_add_options --with-gstreamer-1.0' >> "${srcdir}/nightingale-hacking/nightingale.config"
echo 'ac_add_options --with-taglib-source=system' >> "${srcdir}/nightingale-hacking/nightingale.config"
echo 'ac_add_options --enable-official' >> "${srcdir}/nightingale-hacking/nightingale.config"
-
- cd "${srcdir}/nightingale-hacking/dependencies"
- ln -sf "${srcdir}/linux-${CARCH}" ./
}
-build() {
- cd "${srcdir}/nightingale-hacking"
+build() {
+ msg "Building static dependencies xulrunner and sqlite..."
+
+ # it makes more sense to me to force a fresh build of everything
+ # so i am now
+ if [ -d "${srcdir}/linux-${CARCH}" ]; then
+ rm -rf "${srcdir}/linux-${CARCH}"
+ fi
+
+ if [ -d "${srcdir}/nightingale-hacking/dependencies/linux-${CARCH}" ]; then
+ rm -rf "${srcdir}/nightingale-hacking/dependencies/linux-${CARCH}"
+ fi
+
+ mkdir "${srcdir}/linux-${CARCH}"
+ # for whatever reason the lack of the below broke sqlite
+ # it for whatever reason builds both versions without a make target for release only
+ mkdir -p "${srcdir}/linux-${CARCH}/sqlite/debug"
+ mkdir -p "${srcdir}/linux-${CARCH}/sqlite/release"
+ mkdir -p "${srcdir}/linux-${CARCH}/xulrunner-1.9.2/release"
+
+ cd "${srcdir}/nightingale-deps"
+
+ # xul 1.9.2 won't build without this
+ unset CPPFLAGS
+
+ export SB_VENDOR_BINARIES_CO_ROOT=${srcdir}
+ export SB_VENDOR_BUILD_ROOT=${srcdir}
+ export CXXFLAGS="$CXXFLAGS -fpermissive"
+
+ # gcc6 and higher doesn't play nice with ngale and deps
export CC=gcc-5
export CXX=g++-5
-
- make
+ echo "export CC=gcc-5" >> "${srcdir}/nightingale-deps/xulrunner-1.9.2/mozconfigs/xulrunner.linux.release.${CARCH}.mozconfig"
+ echo "export CXX=g++-5" >> "${srcdir}/nightingale-deps/xulrunner-1.9.2/mozconfigs/xulrunner.linux.release.${CARCH}.mozconfig"
+
+ msg2 "Building xulrunner 1.9.2...\n"
+ make -C xulrunner-1.9.2 -f Makefile.songbird xr-build-release
+ make -C xulrunner-1.9.2 -f Makefile.songbird xr-packaging-release
+
+ msg2 "Building sqlite...\n"
+ cd sqlite
+ autoreconf --force --install
+ cd ..
+ make -C sqlite -f Makefile.songbird
+ strip --strip-all "${srcdir}/linux-$(uname -m)/sqlite/release/bin/sqlite3"
+ strip --strip-debug "${srcdir}/linux-$(uname -m)/sqlite/release/lib/libsqlite3.a"
+
+ mv "${srcdir}/linux-${CARCH}" "${srcdir}/nightingale-hacking/dependencies/"
+
+ msg2 "Building Nightingale...\n"
+ cd "${srcdir}/nightingale-hacking"
+ make
+
# copy the add-ons first
[ -d ../xpi-stage ] && rm -rf ../xpi-stage
cp -a "${srcdir}/nightingale-hacking/compiled/xpi-stage" "${srcdir}"