summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-08-27 20:43:46 +0200
committerMichael Straube2017-08-27 20:43:46 +0200
commitd1e4135be52e5a70dfa34c661794393427346fdc (patch)
treef6dbbae836f10da0573f7544225619dfd84acb53
parentf1098672939f3de59a6100bfbdf3d96df8036ccb (diff)
downloadaur-d1e4135be52e5a70dfa34c661794393427346fdc.tar.gz
Update URLs, add optional levels
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 554955c93d2e..96369c5a6f96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = nikki
- pkgdesc = Nikki and the robots. A game where you try to cross those evil plans on behalf of a secret organization.
+ pkgdesc = Nikki and the Robots platformer game
pkgver = 1.0
- pkgrel = 5
- url = http://abandon
+ pkgrel = 6
+ url = https://github.com/nikki-and-the-robots
arch = i686
arch = x86_64
license = LGPL
@@ -10,9 +10,12 @@ pkgbase = nikki
depends = libsndfile
depends = openal
depends = qt4
+ optdepends = nikki-levels-git: community levels
options = !strip
- source = http://dl.gamux.org/game/download/games/i386/clientgame/nikki/nikki.tar.gz
- sha256sums = 387bfa1d5e602686539eb2371d9d1bdeea13f263f631b26f0af8061e8daab4bb
+ source_i686 = https://github.com/nikki-and-the-robots/nikki/releases/download/1.0/nikki-1.0-marley-linux-i386.tar.gz
+ sha256sums_i686 = 387bfa1d5e602686539eb2371d9d1bdeea13f263f631b26f0af8061e8daab4bb
+ source_x86_64 = https://github.com/nikki-and-the-robots/nikki/releases/download/1.0/nikki-1.0-marley-linux-x86_64.tar.gz
+ sha256sums_x86_64 = 6d642c03959afc4bcd6d846c61d80eae27d58dded5a957858d18ca7d7d5c9df7
pkgname = nikki
diff --git a/PKGBUILD b/PKGBUILD
index 9e064a425a3b..6f9fdcbbd331 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
-# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
+# Maintainer: Michael Straube <straubem@gmx.de>
+# Contributor: Aaron Fischer <mail@aaron-fischer.net>
# Contributor: carstene1ns <url/mail: arch carsten-teibes de>
# Contributor: David Zaragoza <david@zaragoza.com.ve>
pkgname=nikki
pkgver=1.0
-pkgrel=5
-pkgdesc="Nikki and the robots. A game where you try to cross those evil plans on behalf of a secret organization."
-arch=("i686" "x86_64")
-url="http://abandon"
-license=("LGPL" "CCPL")
-depends=("libsndfile" "openal" "qt4")
-source=("http://dl.gamux.org/game/download/games/i386/clientgame/nikki/$pkgname.tar.gz")
-sha256sums=("387bfa1d5e602686539eb2371d9d1bdeea13f263f631b26f0af8061e8daab4bb")
-
-if [ "$CARCH" == "x86_64" ]; then
- source=("http://dl.gamux.org/game/download/games/i386/clientgame/nikki/$pkgname-64.tar.gz")
- sha256sums=("6d642c03959afc4bcd6d846c61d80eae27d58dded5a957858d18ca7d7d5c9df7")
-fi
-
-options=("!strip")
+pkgrel=6
+pkgdesc="Nikki and the Robots platformer game"
+arch=('i686' 'x86_64')
+url="https://github.com/nikki-and-the-robots"
+license=('LGPL' 'CCPL')
+depends=('libsndfile' 'openal' 'qt4')
+optdepends=('nikki-levels-git: community levels')
+options=('!strip')
+source_i686=("https://github.com/nikki-and-the-robots/nikki/releases/download/$pkgver/nikki-$pkgver-marley-linux-i386.tar.gz")
+source_x86_64=("https://github.com/nikki-and-the-robots/nikki/releases/download/$pkgver/nikki-$pkgver-marley-linux-x86_64.tar.gz")
+sha256sums_i686=('387bfa1d5e602686539eb2371d9d1bdeea13f263f631b26f0af8061e8daab4bb')
+sha256sums_x86_64=('6d642c03959afc4bcd6d846c61d80eae27d58dded5a957858d18ca7d7d5c9df7')
package() {
cd nikki