summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-08-27 20:44:26 +0200
committerMichael Straube2017-08-27 20:44:26 +0200
commitf68c63bbef053e6bc850bbc904ee502b57c61a24 (patch)
tree530a6dac2b7bc08ae6a1074bf16f1d6c2391b9cd
downloadaur-f68c63bbef053e6bc850bbc904ee502b57c61a24.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68795f6a17eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nikki-levels-git
+ pkgdesc = Community levels for Nikki and the Robots
+ pkgver = r4.e654797
+ pkgrel = 1
+ url = https://github.com/nikki-and-the-robots
+ arch = any
+ license = CCPL
+ makedepends = git
+ depends = nikki
+ options = !strip
+ source = git+https://github.com/nikki-and-the-robots/nikki-levels.git
+ sha256sums = SKIP
+
+pkgname = nikki-levels-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a481441359b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Michael Straube <straubem@gmx.de>
+
+pkgname=nikki-levels-git
+pkgver=r4.e654797
+pkgrel=1
+pkgdesc="Community levels for Nikki and the Robots"
+arch=('any')
+url="https://github.com/nikki-and-the-robots"
+license=('CCPL')
+depends=('nikki')
+makedepends=('git')
+options=('!strip')
+source=('git+https://github.com/nikki-and-the-robots/nikki-levels.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+ rm community-levels/community-levels-2012-09-23.zip
+}
+
+package() {
+ cd ${pkgname%-git}
+ install -d "$pkgdir"/opt/nikki/data/standardLevels
+ cp -r community-levels "$pkgdir"/opt/nikki/data/standardLevels
+}