summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Warrick2018-03-31 20:00:33 +0200
committerChris Warrick2018-03-31 20:00:33 +0200
commit83f841961d80a0777701fe504090232958ae742a (patch)
tree86c40c02cea9c8477b2a059263cda7995ce4bef3
parentf584c0a7cc4ead02b2dc2fa1a270b4c61b9baf05 (diff)
downloadaur-83f841961d80a0777701fe504090232958ae742a.tar.gz
Make sure /usr/share/doc directory exists and use 8dev.x.y version numbering scheme
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff9f069c4d96..ec0f55aaa6ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nikola-git
pkgdesc = A modular, fast, simple, static website generator. (git version)
- pkgver = 7.8.14.r1.gfee4d191
+ pkgver = 8dev.r330.g2d759c5e
pkgrel = 1
url = https://getnikola.com/
arch = any
@@ -35,7 +35,7 @@ pkgbase = nikola-git
optdepends = python-ghp-import>=0.4.1: for uploading to GitHub Pages
optdepends = python-micawber: for embedding media in posts
optdepends = python-phpserialize: for WordPress imports
- optdepends = python-ws4py: for nikola auto
+ optdepends = python-aiohttp: for nikola auto
optdepends = python-watchdog: for nikola auto
conflicts = python-nikola
conflicts = python2-nikola
diff --git a/PKGBUILD b/PKGBUILD
index 01b6df6000a6..e6d1ff2f810b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pyname=nikola
_gitname=nikola
pkgname=nikola-git
-pkgver=7.8.14.r1.gfee4d191
+pkgver=8dev.r330.g2d759c5e
pkgrel=1
pkgdesc='A modular, fast, simple, static website generator. (git version)'
arch=('any')
@@ -25,7 +25,7 @@ optdepends=('python-jinja: for Jinja2 themes'
'python-ghp-import>=0.4.1: for uploading to GitHub Pages'
'python-micawber: for embedding media in posts'
'python-phpserialize: for WordPress imports'
- 'python-ws4py: for nikola auto'
+ 'python-aiohttp: for nikola auto'
'python-watchdog: for nikola auto')
makedepends=('git')
source=("git+https://github.com/getnikola/${_gitname}.git" "make_tab_completion.py")
@@ -35,7 +35,8 @@ replaces=('python-nikola-git' 'python2-nikola-git' 'python-nikola-doc-git')
pkgver() {
cd "${srcdir}/${_gitname}"
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g'
+ #git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g'
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g;s/7.8.8/8dev/'
}
package() {
@@ -44,6 +45,7 @@ package() {
ln -s ${_gitname} "${pkgdir}/usr/bin/${_gitname}3"
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname}"
install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -m644 docs/man/nikola.1.gz "${pkgdir}/usr/share/man/man1/nikola.1.gz"
install -m644 docs/manual.rst "${pkgdir}/usr/share/doc/${pkgname}/manual.rst"