summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChengrui Chen2023-02-04 21:58:05 +0800
committerChengrui Chen2023-02-04 21:58:05 +0800
commit2f1c74fc131c0b8511ebd2781185360a2bc74f7b (patch)
tree6730ed8503c8f9b85006b259f1a7db2947847c80
parentefb2dbe89ac68e27ce24539a3014506e4b30fbe7 (diff)
downloadaur-2f1c74fc131c0b8511ebd2781185360a2bc74f7b.tar.gz
use new csources_v2
- fix: reference is not a tree: xxx
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--makepkg-conf.patch9
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e19842d8318b..3f2a0aec15d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nim-git
pkgdesc = Nim is a statically typed compiled systems programming language. It combines successful concepts from mature languages like Python, Ada and Modula. Its design focuses on efficiency, expressiveness, and elegance (in that order of priority).
- pkgver = 1.4.6.r1321.a9ae5fe5b
+ pkgver = 1.6.8.r1070.9afb466d73
pkgrel = 1
epoch = 1
arch = x86_64
@@ -12,13 +12,13 @@ pkgbase = nim-git
backup = etc/nim/nimdoc.tex.cfg
backup = etc/nim/rename.rules.cfg
source = git+https://github.com/nim-lang/Nim
- source = git+https://github.com/nim-lang/csources_v1
+ source = git+https://github.com/nim-lang/csources_v2
source = git+https://github.com/nim-lang/nimble
source = makepkg-conf.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 98417afe7b99aa978f57aa724a962d79d7633fcd702a5fbe2d14c67c94447dd1
+ sha256sums = a70ff09cea18ddf0b13fe732846426a7a0c10e9f4187a62228b3c2e3d091d996
pkgname = nim-git
url = https://nim-lang.org/
@@ -59,4 +59,3 @@ pkgname = nim-gdb-git
provides = nim-gdb
conflicts = nimp-gdb
backup =
-
diff --git a/PKGBUILD b/PKGBUILD
index 0e6724da030e..e2c65efb675a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Dan Beste <dan.ray.beste+aur@gmail.com>
+# Maintainer: Chengrui Chen <chengruichen3@gmail.com>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Dominik Picheta <morfeusz8@gmail.com>
@@ -10,7 +11,7 @@ pkgbase='nim-git'
pkgname=('nim-git' 'nimble-git' 'nimsuggest-git' 'nimpretty-git' 'nim-gdb-git')
pkgdesc='Nim is a statically typed compiled systems programming language. It combines successful concepts from mature languages like Python, Ada and Modula. Its design focuses on efficiency, expressiveness, and elegance (in that order of priority).'
epoch=1
-pkgver=1.4.6.r1321.a9ae5fe5b
+pkgver=1.6.8.r1070.9afb466d73
pkgrel=1
arch=('x86_64')
groups=('nim')
@@ -24,14 +25,14 @@ backup=(
makedepends=('git')
source=(
'git+https://github.com/nim-lang/Nim'
- 'git+https://github.com/nim-lang/csources_v1'
+ 'git+https://github.com/nim-lang/csources_v2'
'git+https://github.com/nim-lang/nimble'
'makepkg-conf.patch'
)
-sha256sums=(
- 'SKIP' 'SKIP' 'SKIP'
- '98417afe7b99aa978f57aa724a962d79d7633fcd702a5fbe2d14c67c94447dd1'
-)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'a70ff09cea18ddf0b13fe732846426a7a0c10e9f4187a62228b3c2e3d091d996')
_tag() {
# Grab the most recent non-annotated tag:
@@ -64,11 +65,11 @@ prepare() {
# Upstream "pins" supported commits:
local -r hash="$(grep 'nim_csourcesHash' config/build_config.txt | grep -Eio '[0-9a-z]{40}')"
- [[ -d ./csources_v1 ]] && rm -rf ./csources_v1
+ [[ -d ./csources_v2 ]] && rm -rf ./csources_v2
- cp -r "${srcdir}/csources_v1" .
+ cp -r "${srcdir}/csources_v2" .
- cd csources_v1
+ cd csources_v2
# Checkout the "pinned" commit:
git -c advice.detachedHead=false checkout "$hash"
diff --git a/makepkg-conf.patch b/makepkg-conf.patch
index 59674656c63d..2aca37549492 100644
--- a/makepkg-conf.patch
+++ b/makepkg-conf.patch
@@ -1,12 +1,13 @@
diff --git a/makefile b/makefile
-index 503c030..4146ba2 100644
+index 855c358..54a9d59 100644
--- a/makefile
+++ b/makefile
@@ -3,7 +3,7 @@
# To regenerate run ``niminst csource`` or ``koch csource``
CC ?= gcc
--CFLAGS += -Ic_code -w -O3 -fno-strict-aliasing
-+CFLAGS += -Ic_code -w -fno-strict-aliasing
- LDFLAGS +=
+-CFLAGS += -Ic_code -w -fmax-errors=3 -O3 -fno-strict-aliasing -fno-ident -fno-math-errno
++CFLAGS += -Ic_code -w -fmax-errors=3 -fno-strict-aliasing -fno-ident -fno-math-errno
+ LDFLAGS +=
binDir = bin
+