summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan R Beste2021-05-07 15:34:51 -0500
committerDan R Beste2021-05-07 15:34:51 -0500
commitae1de539bafc311251a15ffe648f2c0ba4c3d080 (patch)
treeed80fbd1caf4f689cb9e184f59331fd3fe931173
parentba4c95d4b0817ab716badeb99207b8be72b1e6dc (diff)
downloadaur-ae1de539bafc311251a15ffe648f2c0ba4c3d080.tar.gz
upgpkg: nim-git 11.4.6.r1304.98c29c01e-1
Updates to nim-git's PKGBUILD - Use pinned csources_v1 hash
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fcd176755c8..1c7e8b70eca5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -61,15 +61,23 @@ pkgver() {
prepare() {
cd Nim
+ # Upstream "pins" supported commits:
+ local -r hash="$(grep 'Hash' config/build_config.txt | grep -Eio '[0-9a-z]{40}')"
+
[[ -d ./csources_v1 ]] && rm -rf ./csources_v1
cp -r "${srcdir}/csources_v1" .
+ cd csources_v1
+
+ # Checkout the "pinned" commit:
+ git -c advice.detachedHead=false checkout "$hash"
+
# Remove hardcoded `-O3` from makefile's COMP_FLAGS:
- patch ./csources_v1/makefile \
- --strip=1 \
- --fuzz 5 \
- -N \
+ patch makefile \
+ --strip=1 \
+ --fuzz 5 \
+ -N \
< "${srcdir}/makepkg-conf.patch"
}