summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan R Beste2021-05-07 14:42:49 -0500
committerDan R Beste2021-05-07 14:42:49 -0500
commitba4c95d4b0817ab716badeb99207b8be72b1e6dc (patch)
tree5b81b2b1ace705fd330a22b6121e4ee99a36e381
parenta7259b022db1f715980b7aff6b1e5c27fbbb3316 (diff)
downloadaur-ba4c95d4b0817ab716badeb99207b8be72b1e6dc.tar.gz
upgpkg: nim-git 11.4.6.r1304.98c29c01e-1
- Migrate to csources_v1 - Migrate to build_all.sh - Remove nimfind
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD59
-rw-r--r--makepkg-conf.patch37
3 files changed, 35 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a333eb9e3bcc..0761c44c9920 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nim-git
pkgdesc = Nim is a statically typed compiled systems programming language. It combines successful concepts from mature languages like Python, Ada and Modula. Its design focuses on efficiency, expressiveness, and elegance (in that order of priority).
- pkgver = 1.4.2.r591.44ceefa9f
+ pkgver = 1.4.6.r1304.98c29c01e
pkgrel = 1
epoch = 1
arch = x86_64
@@ -12,13 +12,13 @@ pkgbase = nim-git
backup = etc/nim/nimdoc.tex.cfg
backup = etc/nim/rename.rules.cfg
source = git+https://github.com/nim-lang/Nim
- source = git+https://github.com/nim-lang/csources
+ source = git+https://github.com/nim-lang/csources_v1
source = git+https://github.com/nim-lang/nimble
source = makepkg-conf.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 9d73290e81a2e2a79f7bb8058d47854d90ba9301dda1bee107294e2d82f631bf
+ sha256sums = 98417afe7b99aa978f57aa724a962d79d7633fcd702a5fbe2d14c67c94447dd1
pkgname = nim-git
url = https://nim-lang.org/
@@ -33,6 +33,7 @@ pkgname = nimble-git
license = BSD
provides = nimble
conflicts = nimble
+ backup =
pkgname = nimsuggest-git
pkgdesc = Nimsuggest is a tool that helps to give editors IDE like capabilities.
@@ -40,6 +41,7 @@ pkgname = nimsuggest-git
license = MIT
provides = nimsuggest
conflicts = nimsuggest
+ backup =
pkgname = nimpretty-git
pkgdesc = Standard tool for pretty printing.
@@ -47,13 +49,7 @@ pkgname = nimpretty-git
license = MIT
provides = nimpretty
conflicts = nimpretty
-
-pkgname = nimfind-git
- pkgdesc = Nimfind is a tool that helps to give editors IDE like capabilities.
- url = https://github.com/nim-lang/Nim
- license = MIT
- provides = nimfind
- conflicts = nimfind
+ backup =
pkgname = nim-gdb-git
pkgdesc = GDB pretty printing for Nim language.
@@ -62,4 +58,5 @@ pkgname = nim-gdb-git
depends = gdb
provides = nim-gdb
conflicts = nimp-gdb
+ backup =
diff --git a/PKGBUILD b/PKGBUILD
index 59f580e2b91f..1fcd176755c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,10 @@
# Contributor: Zion Nimchuk <zionnimchuk@gmail.com>
pkgbase='nim-git'
-pkgname=('nim-git' 'nimble-git' 'nimsuggest-git' 'nimpretty-git' 'nimfind-git' 'nim-gdb-git')
+pkgname=('nim-git' 'nimble-git' 'nimsuggest-git' 'nimpretty-git' 'nim-gdb-git')
pkgdesc='Nim is a statically typed compiled systems programming language. It combines successful concepts from mature languages like Python, Ada and Modula. Its design focuses on efficiency, expressiveness, and elegance (in that order of priority).'
epoch=1
-pkgver=1.4.2.r591.44ceefa9f
+pkgver=1.4.6.r1304.98c29c01e
pkgrel=1
arch=('x86_64')
groups=('nim')
@@ -24,13 +24,13 @@ backup=(
makedepends=('git')
source=(
'git+https://github.com/nim-lang/Nim'
- 'git+https://github.com/nim-lang/csources'
+ 'git+https://github.com/nim-lang/csources_v1'
'git+https://github.com/nim-lang/nimble'
'makepkg-conf.patch'
)
sha256sums=(
'SKIP' 'SKIP' 'SKIP'
- '9d73290e81a2e2a79f7bb8058d47854d90ba9301dda1bee107294e2d82f631bf'
+ '98417afe7b99aa978f57aa724a962d79d7633fcd702a5fbe2d14c67c94447dd1'
)
_tag() {
@@ -61,43 +61,22 @@ pkgver() {
prepare() {
cd Nim
- [[ -d ./csources ]] && rm -rf ./csources
+ [[ -d ./csources_v1 ]] && rm -rf ./csources_v1
- cp -r "${srcdir}/csources" .
+ cp -r "${srcdir}/csources_v1" .
- # Remove `-O3` from build.sh's COMP_FLAGS:
- patch ./csources/build.sh \
- --strip=1 \
- --fuzz 5 \
- -N \
+ # Remove hardcoded `-O3` from makefile's COMP_FLAGS:
+ patch ./csources_v1/makefile \
+ --strip=1 \
+ --fuzz 5 \
+ -N \
< "${srcdir}/makepkg-conf.patch"
}
build() {
cd Nim
- # Build the pre-generated C sources of the Nim compiler which aid in
- # bootstrapping:
- cd csources
- ./build.sh
- cd -
-
- # Build a release version of the "koch" maintenance program:
- ./bin/nim c -d:release --skipUserCfg --skipParentCfg koch
- # Build a release version of the nim compiler:
- ./koch boot \
- -d:nativeStacktrace \
- -d:release \
- -d:useGnuReadline \
- --skipUserCfg \
- --skipParentCfg
- # Build nimsuggest, nimgrep, and nimpretty:
- ./koch tools -d:release --skipUserCfg --skipParentCfg
-
- # Build nimrtl.nim:
- cd lib
- ../bin/nim c --app:lib -d:createNimRtl -d:release nimrtl.nim
- cd -
+ /usr/bin/env sh build_all.sh
}
package_nim-git() {
@@ -150,6 +129,7 @@ package_nim-git() {
}
package_nimble-git() {
+ backup=()
pkgdesc="Package manager for the Nim programming language"
url="https://github.com/nim-lang/nimble"
license=('BSD')
@@ -180,6 +160,7 @@ package_nimble-git() {
}
package_nimsuggest-git() {
+ backup=()
pkgdesc='Nimsuggest is a tool that helps to give editors IDE like capabilities.'
url='https://github.com/nim-lang/nimsuggest'
license=('MIT')
@@ -190,6 +171,7 @@ package_nimsuggest-git() {
}
package_nimpretty-git() {
+ backup=()
pkgdesc='Standard tool for pretty printing.'
url='https://github.com/nim-lang/Nim/tree/devel/nimpretty'
license=('MIT')
@@ -199,17 +181,8 @@ package_nimpretty-git() {
install -Dm 755 'Nim/bin/nimpretty' -t "${pkgdir}/usr/bin"
}
-package_nimfind-git() {
- pkgdesc='Nimfind is a tool that helps to give editors IDE like capabilities.'
- url='https://github.com/nim-lang/Nim'
- license=('MIT')
- provides=('nimfind')
- conflicts=('nimfind')
-
- install -Dm 755 'Nim/bin/nimfind' -t "${pkgdir}/usr/bin"
-}
-
package_nim-gdb-git() {
+ backup=()
pkgdesc='GDB pretty printing for Nim language.'
url='https://github.com/nim-lang/Nim'
license=('MIT')
diff --git a/makepkg-conf.patch b/makepkg-conf.patch
index 56b36b0eda3f..59674656c63d 100644
--- a/makepkg-conf.patch
+++ b/makepkg-conf.patch
@@ -1,25 +1,12 @@
-From 36f5830ea50af5c3c21fc0e132d25273c0391879 Mon Sep 17 00:00:00 2001
-From: Dan Beste <dan.ray.beste@gmail.com>
-Date: Mon, 24 Sep 2018 11:19:01 -0500
-Subject: [PATCH] C{,XX}FLAG normalization
-
----
- build.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/build.sh b/build.sh
-index 3caee529..b4fdda14 100755
---- a/build.sh
-+++ b/build.sh
-@@ -40,7 +40,7 @@ done
-
- CC="gcc"
- LINKER="gcc"
--COMP_FLAGS="${CPPFLAGS:-} ${CFLAGS:-} -w -O3 -fno-strict-aliasing$extraBuildArgs"
-+COMP_FLAGS="${CPPFLAGS:-} ${CFLAGS:-} -w -fno-strict-aliasing"
- LINK_FLAGS="${LDFLAGS:-} "
- PS4=""
- # platform detection
---
-2.19.0
-
+diff --git a/makefile b/makefile
+index 503c030..4146ba2 100644
+--- a/makefile
++++ b/makefile
+@@ -3,7 +3,7 @@
+ # To regenerate run ``niminst csource`` or ``koch csource``
+
+ CC ?= gcc
+-CFLAGS += -Ic_code -w -O3 -fno-strict-aliasing
++CFLAGS += -Ic_code -w -fno-strict-aliasing
+ LDFLAGS +=
+ binDir = bin