summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2018-06-12 12:32:03 -0400
committerAndy Weidenbaum2018-06-12 12:32:03 -0400
commitfb38bccd3862c6de349127dd898a50a429356d73 (patch)
treeef8b9b36f448c6dec6ee63e72335ded27d25250a
parent159da1c77a2477bb9c38b40d911fb2862cd73ce3 (diff)
downloadaur-fb38bccd3862c6de349127dd898a50a429356d73.tar.gz
update pkgver to 20180612, building pdf optional
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86411a825d02..bf525049e404 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,10 @@
-# Generated by mksrcinfo v8
-# Tue Dec 19 23:04:19 UTC 2017
pkgbase = nim-git
- pkgver = 20170710
+ pkgver = 20180612
pkgrel = 1
arch = i686
arch = x86_64
groups = nim
makedepends = git
- makedepends = texlive-bin
- makedepends = texlive-core
- makedepends = texlive-fontsextra
source = git+https://github.com/nim-lang/Nim
source = git+https://github.com/nim-lang/Nim.wiki
source = git+https://github.com/nim-lang/csources
diff --git a/PKGBUILD b/PKGBUILD
index aee4ef606bd4..a6ce1de0f684 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,18 @@
# Contributor: Jesus Alvarez <jeezusjr@gmail.com>
# Contributor: Zion Nimchuk <zionnimchuk@gmail.com>
+# build PDF documentation
+_pdf=false
+
pkgbase=nim-git
pkgname=('nim-git' 'nimble-git' 'nimsuggest-git')
-pkgver=20170710
+pkgver=20180612
pkgrel=1
arch=('i686' 'x86_64')
groups=('nim')
-makedepends=('git' 'texlive-bin' 'texlive-core' 'texlive-fontsextra')
+makedepends=('git')
+[[ "$_pdf" == true ]] \
+ && makedepends+=('texlive-bin' 'texlive-core' 'texlive-fontsextra')
source=(git+https://github.com/nim-lang/Nim
git+https://github.com/nim-lang/Nim.wiki
git+https://github.com/nim-lang/csources
@@ -42,8 +47,10 @@ build() {
./bin/nim c -d:release koch
./koch boot -d:release -d:nativeStacktrace -d:useGnuReadline
- msg2 'Building Nim PDF documentation...'
- ./koch pdf
+ if [[ "$_pdf" == true ]]; then
+ msg2 'Building Nim PDF documentation...'
+ ./koch pdf
+ fi
msg2 'Building Nimble...'
./koch nimble