summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBumsik Kim2018-08-09 11:12:25 -0400
committerBumsik Kim2018-08-09 11:19:29 -0400
commit82501cbe46032514fc871cf8a5646a56b6be2eb3 (patch)
treeed24665e98dd4dbcb938f06c70a6696cbeb11279
downloadaur-82501cbe46032514fc871cf8a5646a56b6be2eb3.tar.gz
initial commit
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD39
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d9ad7e73e6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = nimf
+ pkgdesc = Nimf is an input method framework.
+ pkgver = 2018.08.06
+ pkgrel = 1
+ url = https://gitlab.com/nimf-i18n/nimf
+ arch = any
+ license = LGPL3
+ makedepends = binutils
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gcc
+ makedepends = make
+ makedepends = glib2
+ makedepends = intltool
+ makedepends = gtk3
+ makedepends = gtk2
+ makedepends = qt4
+ makedepends = qt5-base
+ makedepends = libappindicator-gtk3
+ makedepends = librsvg
+ makedepends = noto-fonts-cjk
+ makedepends = libhangul
+ makedepends = anthy
+ makedepends = libchewing
+ makedepends = librime
+ makedepends = libxkbcommon
+ makedepends = wayland
+ depends = glib2
+ depends = gtk3
+ depends = gtk2
+ depends = qt4
+ depends = qt5-base
+ depends = libappindicator-gtk3
+ depends = libhangul
+ depends = anthy
+ depends = libchewing
+ depends = librime
+ depends = libxkbcommon
+ depends = wayland
+ optdepends = brise: Rime schema repository
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ source = srcdir::git+https://gitlab.com/nimf-i18n/nimf#commit=f806f6da86f8b4cf168983467953c9a3be7595d6
+ md5sums = SKIP
+
+pkgname = nimf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2a8443911be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Project Author: Hodong Kim <https://gitlab.com/hodong>
+# PKGBUILD Author: Hodong Kim <https://gitlab.com/hodong>
+# PKGBUILD Maintainer: Bumsik Kim <k.bumsik@gmail.com>
+
+#
+# PKGBUILD
+# This file is part of Nimf.
+#
+# Unlike other files in the Nimf project,
+# this PKGBUILD file is in the public domain.
+
+pkgname=nimf
+pkgver=2018.08.06
+pkgrel=1
+pkgdesc="Nimf is an input method framework."
+arch=('any')
+url="https://gitlab.com/nimf-i18n/nimf"
+license=('LGPL3')
+makedepends=('binutils' 'autoconf' 'automake' 'gcc' 'make' 'glib2' 'intltool'
+ 'gtk3' 'gtk2' 'qt4' 'qt5-base' 'libappindicator-gtk3' 'librsvg'
+ 'noto-fonts-cjk' 'libhangul' 'anthy' 'libchewing' 'librime'
+ 'libxkbcommon' 'wayland')
+depends=('glib2' 'gtk3' 'gtk2' 'qt4' 'qt5-base' 'libappindicator-gtk3'
+ 'libhangul' 'anthy' 'libchewing' 'librime' 'libxkbcommon' 'wayland')
+optdepends=('brise: Rime schema repository'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+source=("srcdir::git+https://gitlab.com/nimf-i18n/nimf#commit=f806f6da86f8b4cf168983467953c9a3be7595d6")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/nimf-master"
+ ./autogen.sh --prefix=/usr
+ make -j 4
+}
+
+package() {
+ cd "$srcdir/nimf-master"
+ make DESTDIR="${pkgdir}/" install
+}