summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-06 04:00:25 +0300
committerDimitris Kiziridis2020-07-06 04:00:25 +0300
commitcf53e0775b08000b8927f7e7c0d809ae8920885d (patch)
tree44ddeac72fde3b6c9041be58ebdaf1b06dfd3d44
downloadaur-cf53e0775b08000b8927f7e7c0d809ae8920885d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9a502757957
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nimsynth-git
+ pkgdesc = A modular synth and sequencer made with Nim
+ pkgver = r150.4985e4c
+ pkgrel = 1
+ url = https://github.com/ftsf/nimsynth
+ arch = x86_64
+ license = custom:unknown
+ makedepends = git
+ makedepends = nim
+ makedepends = nimble
+ depends = glibc
+ provides = nimsynth
+ source = nimsynth::git+https://github.com/ftsf/nimsynth
+ sha256sums = SKIP
+
+pkgname = nimsynth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1424287d707
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=nimsynth-git
+_pkgname=nimsynth
+pkgver=r150.4985e4c
+pkgrel=1
+pkgdesc="A modular synth and sequencer made with Nim"
+arch=('x86_64')
+url='https://github.com/ftsf/nimsynth'
+license=('custom:unknown')
+provides=('nimsynth')
+depends=('glibc')
+makedepends=('git' 'nim' 'nimble')
+source=("nimsynth::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ git checkout nim1.2
+ nimble -y install sndfile nico
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm755 synth "${pkgdir}/usr/bin/${_pkgname}"
+} \ No newline at end of file