summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Burgwin2019-05-26 21:04:20 -0700
committerIan Burgwin2019-05-26 21:04:20 -0700
commitdb856b6de77f6f983726f4f7462113dd3c80e2f4 (patch)
treeb1735c16f08561357f271b9c33756ee207433062
parent0c0a894ebe87fe28e14c6a7e43679edd26194988 (diff)
downloadaur-db856b6de77f6f983726f4f7462113dd3c80e2f4.tar.gz
move python-setuptools to depends for both packages instead of global
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8c9b2f4f646..3b2c7b2dd9e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = ninfs
pkgdesc = FUSE filesystem Python scripts for Nintendo console files
pkgver = 1.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ihaveamac/ninfs
arch = x86_64
license = MIT
makedepends = unzip
- depends = python-setuptools
noextract = ninfs-1.6-src.zip
options = !strip
source = ninfs-1.6-src.zip::https://github.com/ihaveamac/ninfs/releases/download/v1.6/ninfs-1.6-src.zip
@@ -17,6 +16,7 @@ pkgbase = ninfs
pkgname = ninfs
depends = python>=3.6.1
+ depends = python-setuptools
depends = python-pycryptodomex
depends = fuse2
depends = openssl>=1.1
@@ -28,7 +28,8 @@ pkgname = ninfs
pkgname = ninfs-gui
install = NinFSGUI.install
- depends = ninfs=1.6-2
+ depends = ninfs=1.6-3
+ depends = python-setuptools
depends = python-appjar
depends = tk
provides = fuse-3ds-gui
diff --git a/PKGBUILD b/PKGBUILD
index 90a9a20922d4..8d1cf0b06639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
pkgbase=ninfs
pkgname=(ninfs ninfs-gui)
pkgver=1.6
-pkgrel=2
+pkgrel=3
pkgdesc="FUSE filesystem Python scripts for Nintendo console files"
arch=($CARCH)
license=(MIT)
url='https://github.com/ihaveamac/ninfs'
-depends=('python-setuptools')
makedepends=('unzip')
options=(!strip)
_source=("${pkgbase}-${pkgver}-src.zip"{,.asc}"::${url}/releases/download/v${pkgver}/${pkgbase}-${pkgver}-src.zip"{.asc,''})
@@ -23,7 +22,7 @@ build() {
}
package_ninfs() {
- depends=("python>=3.6.1" "python-pycryptodomex" "fuse2" "openssl>=1.1")
+ depends=("python>=3.6.1" "python-setuptools" "python-pycryptodomex" "fuse2" "openssl>=1.1")
conflicts=("fuse-3ds" "fuse-3ds-git" "ninfs-git")
replaces=("fuse-3ds")
provides=("fuse-3ds")
@@ -34,7 +33,7 @@ package_ninfs() {
}
package_ninfs-gui() {
- depends=("ninfs=$pkgver-$pkgrel" "python-appjar" "tk")
+ depends=("ninfs=$pkgver-$pkgrel" "python-setuptools" "python-appjar" "tk")
conflicts=("fuse-3ds-gui-git" "fuse-3ds-gui" "ninfs-gui-git")
replaces=("fuse-3ds-gui")
provides=("fuse-3ds-gui")