summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluigoalma2019-04-18 14:20:12 +0100
committerluigoalma2019-04-18 14:20:12 +0100
commit53325364753d8d3df28d5ca0a43310478625529d (patch)
tree44cf5e98a19621503774fc188f98ba3fb21f8a5c
parentd0bf92a7f3001f5f5570038d5080e5888cdaa87e (diff)
downloadaur-53325364753d8d3df28d5ca0a43310478625529d.tar.gz
Replace fuse-3ds
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD12
2 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baf4ea71f7ed..bab4623a6b8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ninfs-git
pkgdesc = FUSE filesystem Python scripts for Nintendo console files
pkgver = 1.4.r0.g996fe4c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ihaveamac/ninfs
arch = x86_64
license = MIT
@@ -17,13 +17,25 @@ pkgname = ninfs-git
depends = python-pycryptodomex
depends = fuse2
depends = openssl>=1.1
- provides = ninfs=1.4.r0.g996fe4c-1
+ provides = fuse-3ds-git
+ provides = fuse-3ds
+ provides = ninfs=1.4.r0.g996fe4c-2
+ conflicts = fuse-3ds-git
+ conflicts = fuse-3ds
conflicts = ninfs
+ replaces = fuse-3ds-git
+ replaces = fuse-3ds
pkgname = ninfs-gui-git
install = NinFSGUI.install
- depends = ninfs-git=1.4.r0.g996fe4c-1
+ depends = ninfs-git=1.4.r0.g996fe4c-2
depends = python-appjar
- provides = ninfs-gui=1.4.r0.g996fe4c-1
+ provides = fuse-3ds-gui-git
+ provides = fuse-3ds-gui
+ provides = ninfs-gui=1.4.r0.g996fe4c-2
+ conflicts = fuse-3ds-gui-git
+ conflicts = fuse-3ds-gui
conflicts = ninfs-gui
+ replaces = fuse-3ds-gui-git
+ replaces = fuse-3ds-gui
diff --git a/PKGBUILD b/PKGBUILD
index b0ebdcf397d0..10dcca1b3b4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgbase=ninfs-git
pkgname=(ninfs-git ninfs-gui-git)
pkgver=1.4.r0.g996fe4c
-pkgrel=1
+pkgrel=2
pkgdesc="FUSE filesystem Python scripts for Nintendo console files"
arch=($CARCH)
license=(MIT)
@@ -23,8 +23,9 @@ build() {
package_ninfs-git() {
depends=("python>=3.6.1" "python-pycryptodomex" "fuse2" "openssl>=1.1")
- conflicts=(ninfs)
- provides=("ninfs=$pkgver-$pkgrel")
+ conflicts=("fuse-3ds-git" "fuse-3ds" "ninfs")
+ replaces=("fuse-3ds-git" "fuse-3ds")
+ provides=("fuse-3ds-git" "fuse-3ds" "ninfs=$pkgver-$pkgrel")
cd "${srcdir}/ninfs"
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
rm -f "$pkgdir/usr/bin/ninfs"
@@ -33,8 +34,9 @@ package_ninfs-git() {
package_ninfs-gui-git() {
depends=("ninfs-git=$pkgver-$pkgrel" "python-appjar")
- conflicts=(ninfs-gui)
- provides=("ninfs-gui=$pkgver-$pkgrel")
+ conflicts=("fuse-3ds-gui-git" "fuse-3ds-gui" "ninfs-gui")
+ replaces=("fuse-3ds-gui-git" "fuse-3ds-gui")
+ provides=("fuse-3ds-gui-git" "fuse-3ds-gui" "ninfs-gui=$pkgver-$pkgrel")
install="NinFSGUI.install"
cd "${srcdir}/ninfs"
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1