summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:45:57 -0700
committerShadowKyogre2015-06-08 07:45:57 -0700
commit6546f46ac3e1722d9d8438d3f48f1a33e43067b0 (patch)
tree27815b80fd622ab01da69ff5f93d591cab0f793f
downloadaur-6546f46ac3e1722d9d8438d3f48f1a33e43067b0.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD52
-rw-r--r--ninit.install21
4 files changed, 100 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..9a8d1293c0df
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = ninit
+ pkgdesc = A small replacement of init
+ pkgver = 0.14
+ pkgrel = 4
+ url = http://riemann.fmi.uni-sofia.bg/ninit/
+ install = ninit.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = http://riemann.fmi.uni-sofia.bg/ninit/ninit-0.14.tar.bz2
+
+pkgname = ninit
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..932dd264a499
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ninit
+ pkgdesc = A small replacement of init
+ pkgver = 0.14
+ pkgrel = 4
+ url = http://riemann.fmi.uni-sofia.bg/ninit/
+ install = ninit.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = http://riemann.fmi.uni-sofia.bg/ninit/ninit-0.14.tar.bz2
+ md5sums = 3c70d673d2107afcabe97805b2aed407
+
+pkgname = ninit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b9e24fcbbb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: bender02 at gmx dot com
+pkgname=ninit
+pkgver=0.14
+pkgrel=4
+pkgdesc="A small replacement of init"
+arch=('i686' 'x86_64')
+url="http://riemann.fmi.uni-sofia.bg/ninit/"
+license=('GPL2')
+depends=()
+#makedepends=('dietlibc')
+install=ninit.install
+source=(http://riemann.fmi.uni-sofia.bg/$pkgname/$pkgname-$pkgver.tar.bz2)
+md5sums=('3c70d673d2107afcabe97805b2aed407')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # preparations
+ export PATH=$PATH:/opt/diet/bin
+ _CARCH=$CARCH
+ [ "$CARCH" = "i686" ] && _CARCH=i386
+ make clean
+
+ # build: - statically against dietlibc -> 'make withdiet'
+ # - dynamically against glibc -> 'make'
+ # - statically, better than dietlibc -> 'make $CARCH'
+ make $_CARCH
+
+ # this is needed if *not* building against dietlibc:
+ [ -d bin-$_CARCH ] && cp bin-$_CARCH/* .
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ # fix a problem with make install
+ install -d $pkgdir/usr/share/man
+
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install_other
+
+ #don't clutter /etc/ninit with the suggested bin folder containing utilities
+ #instead, place them in /opt/ninit so /etc/ninit can be dedicated to services
+
+ msg "Moving /etc/ninit/bin to /usr/lib/ninit/bin to reduce clutter"
+ mkdir -p "${pkgdir}/usr/lib/ninit/"
+ mv "${pkgdir}/etc/ninit/bin" "${pkgdir}/usr/lib/ninit/bin"
+
+ msg "Moving /etc/ninit/sys to /usr/lib/ninit/sys to reduce clutter"
+ mv "${pkgdir}/etc/ninit/sys" "${pkgdir}/usr/lib/ninit/sys"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ninit.install b/ninit.install
new file mode 100644
index 000000000000..9358207c028d
--- /dev/null
+++ b/ninit.install
@@ -0,0 +1,21 @@
+#Should write this, see http://riemann.fmi.uni-sofia.bg/ninit/install.html#Warning
+#pre_install() {
+#}
+
+post_install() {
+cat << EOF
+==> To boot with ninit add the following to your boot entry parameters:
+==> init=/sbin/ninit -S/usr/lib/ninit/sys
+==> /usr/lib/ninit/sys is /etc/ninit/sys, but it's been moved to /usr/lib/ninit
+==> to make fiddling with /etc/ninit a safer affair.
+==> You can symlink /usr/lib/ninit/sys to /etc/ninit/sys if you don't want to add the -S option.
+==>
+==> For sample service files, see ninit website; in particular
+==> http://riemann.fmi.uni-sofia.bg/ninit/ninit-data.tar.gz
+==> There's also a few examples one can grab from here;
+==> https://github.com/ShadowKyogre/ninit-boot
+==> Or you can use this to convert systemd service files to init files
+EOF
+}
+
+# vim:set ts=2 sw=2 et: