summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2020-03-16 06:13:32 +0100
committerSeverin Glöckner2020-03-16 06:13:32 +0100
commit2551ca3516c1d4690977256e2a3f808e03ff254b (patch)
treeef334945f15555552dd3bca120cb6c5a65760042
parentca89d5b5d7143794c38a23d9c7f47b24a5dfa7c8 (diff)
downloadaur-2551ca3516c1d4690977256e2a3f808e03ff254b.tar.gz
fix for python3.8
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2550d2e619a3..30cd0c5ef1b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ninja-ide-git
pkgdesc = Cross-platform IDE focused on Python application development
pkgver = 20190207
- pkgrel = 1
+ pkgrel = 2
url = http://ninja-ide.org
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 58ba6c0f952b..7b87971e959f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ninja-ide-git
pkgver=20190207
-pkgrel=1
+pkgrel=2
pkgdesc="Cross-platform IDE focused on Python application development"
arch=('any')
url="http://ninja-ide.org"
@@ -29,6 +29,13 @@ prepare() {
ln -sf $srcdir/MANIFEST.in
rm -rf ninja_tests ninja_profiling
+
+ # Work around not being prepared for python 3.8
+ sed -e "s/_ast.Num/_ast.Constant/" \
+ -e "/_ast.Str/ s/^/#/" \
+ -i ninja_ide/tools/introspection.py
+ ln -s grammar37.txt \
+ ninja_ide/intellisensei/parso/python/grammar38.txt
}
build () {