summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2021-06-28 02:35:08 +0200
committerSeverin Glöckner2021-06-28 02:35:08 +0200
commit36779ee255eb8b712929295b576fa6487d0d03e7 (patch)
tree9a3624d79b50cc59a794cf61d0ff0e124f55b28c
parent069c403e3bb85347741920c95916ffe775f73f6a (diff)
downloadaur-36779ee255eb8b712929295b576fa6487d0d03e7.tar.gz
update package for upstream changes
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
-rw-r--r--setup.py12
3 files changed, 23 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f329f636153c..08d3232ed981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ninja-ide-git
pkgdesc = Cross-platform IDE focused on Python application development
- pkgver = 20190207
- pkgrel = 4
+ pkgver = 20210526
+ pkgrel = 1
url = http://ninja-ide.org
arch = any
license = GPL3
@@ -12,13 +12,12 @@ pkgbase = ninja-ide-git
depends = qt5-declarative
depends = python-pycodestyle
depends = python-pyflakes
- options = emptydirs
- source = git+https://github.com/ninja-ide/ninja-ide.git
+ depends = python-jedi
+ source = git+https://github.com/ninja-ide/ninja-ide.git#branch=develop
source = setup.py
source = MANIFEST.in
- md5sums = SKIP
- md5sums = c4dbf95e76d6507e3c087cc6cdaf64b0
- md5sums = e8fd6b8243172d576d032c26d9140285
+ sha256sums = SKIP
+ sha256sums = 1045011c72b3b192b5919a9625f5b838368d3e492f3c7e569c204b119f74721e
+ sha256sums = 0341af903c8947afaba84555054edf80f1177ad22fc0a17be1c6c9d94536498a
pkgname = ninja-ide-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b74cf1938153..11c4c11dc00c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,21 @@
# Contributor: Federico Cinelli <cinelli.federico@gmail.com>
pkgname=ninja-ide-git
-pkgver=20190207
-pkgrel=4
+pkgver=20210526
+pkgrel=1
pkgdesc="Cross-platform IDE focused on Python application development"
arch=('any')
url="http://ninja-ide.org"
license=('GPL3')
-depends=('python-pyqt5' 'qt5-declarative' 'python-pycodestyle' 'python-pyflakes')
+depends=('python-pyqt5' 'qt5-declarative' 'python-pycodestyle' 'python-pyflakes' 'python-jedi')
makedepends=('git' 'python-setuptools')
checkdepends=('python-pytest')
-options=('emptydirs') # for font dir
-source=("git+https://github.com/ninja-ide/ninja-ide.git"
+source=("git+https://github.com/ninja-ide/ninja-ide.git#branch=develop"
"setup.py"
"MANIFEST.in")
-md5sums=('SKIP'
- 'c4dbf95e76d6507e3c087cc6cdaf64b0'
- 'e8fd6b8243172d576d032c26d9140285')
+sha256sums=('SKIP'
+ '1045011c72b3b192b5919a9625f5b838368d3e492f3c7e569c204b119f74721e'
+ '0341af903c8947afaba84555054edf80f1177ad22fc0a17be1c6c9d94536498a')
pkgver() {
cd ninja-ide
@@ -33,15 +32,7 @@ prepare() {
# fix desktop file
sed "/MimeType/d" -i build_files/$pkgname.desktop
echo "MimeType=text/x-python;" >> build_files/$pkgname.desktop
-
- # Work around not being prepared for python 3.8
- # sed -e "s/_ast.Num/_ast.Constant/" \
- # -e "s/_ast.Str/_ast.Constant/" \
- # -i ninja_ide/tools/introspection.py
- # Alternative - can we instead of _ast just use ast,
- # which still has this code for backwards compatibility (for a while)?
- sed -e "/_map_type/,/def _parse_assign/ s/_ast/ast/" \
- -i ninja_ide/tools/introspection.py
+ sed "/Categories/ s/$/Qt;/" -i build_files/$pkgname.desktop
# Updating external dependencies:
@@ -54,7 +45,7 @@ prepare() {
# https://github.com/eamanu/NotImportChecker
# Use newer pyflakes (again, might break things, may resolve #2088)
- sed -e "s/from ninja_ide.dependencies.pyflakes_mod import checker/from pyflakes import checker/" \
+ sed -e "s/from ninja_ide.dependencies.pyflakes_mod/from pyflakes/" \
-i ninja_ide/gui/editor/checkers/errors_checker.py
rm -rf ninja_ide/dependencies/pyflakes_mod/
}
@@ -77,19 +68,13 @@ package() {
#find ninja_ide | sed -e '/.cpython.[0-9]*.pyc/d' -e '/__pycache__/d' | sort > /tmp/ninja-ide-repository-files.txt
- python3 setup.py install --root="$pkgdir" --skip-build -O1
+ python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
- # This is intended as a safeguard, to realize, when many things are missing
+ # This is intended as a safeguard, to realize when many things are missing.
#cd "$pkgdir/usr/lib/python3.9/site-packages/"
#find ninja_ide | sed -e '/.cpython.[0-9]*.pyc/d' -e '/__pycache__/d' | sort > /tmp/ninja-ide-packaged-files.txt
#cd -
- # Do that here instead of earlier, as the links are converted to text files otherwise
- ln -s grammar37.txt "$pkgdir"/usr/lib/python3.9/site-packages/ninja_ide/intellisensei/parso/python/grammar38.txt
- ln -s grammar38.txt "$pkgdir"/usr/lib/python3.9/site-packages/ninja_ide/intellisensei/parso/python/grammar39.txt
-
- # The fonts are now not anymore packaged, but the directory is required
- install -dm755 "$pkgdir"/usr/lib/python3.9/site-packages/ninja_ide/fonts
install -Dm755 ninja-ide.py "$pkgdir/usr/bin/$pkgname"
install -Dm644 ninja_ide/images/icon.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
install -Dm644 icon.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
diff --git a/setup.py b/setup.py
index 217740faa861..ce39d26d0f7d 100644
--- a/setup.py
+++ b/setup.py
@@ -7,9 +7,7 @@ setup(name='Ninja-IDE',
url='http://ninja-ide.org',
download_url='https://github.com/ninja-ide/ninja-ide',
license='GPLv3+',
- package_data={ 'ninja_ide': [ 'intellisensei/jedi/evaluate/compiled/fake/*.pym',
- 'intellisensei/parso/python/grammar*.txt',
- 'extensions/styles/*',
+ package_data={ 'ninja_ide': [ 'extensions/styles/*',
'extensions/syntax/*.json',
'extensions/theme/qss/*',
'extensions/theme/*',
@@ -20,9 +18,10 @@ setup(name='Ninja-IDE',
'images/*',
'images/help/*',
'images/stylesheet/*',
+ 'fonts/*',
'nresources.qrc' ]},
packages=find_packages(exclude=['ninja_profiling', 'ninja_tests', 'ninja_tests.*']),
- python_requires='>=3.4',
+ python_requires='>=3.7',
install_requires=['pyqt5', 'pycodestyle', 'pyflakes'],
extras_require={'tests': ['pytest', 'pytest-qt']},
#entry_points={'console_scripts':['ninja-ide=ninja_ide.__init__:setup_and_run']},
@@ -38,10 +37,9 @@ setup(name='Ninja-IDE',
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3 :: Only',
'Topic :: Software Development',
'Topic :: Text Editors',