summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2018-10-07 06:41:33 +0200
committerSeverin Glöckner2018-10-07 06:48:42 +0200
commitd172a5bb8e571dd9d4c3a2767f54982ab61b2537 (patch)
tree1bb04d575de90e30a55ec8baf80e415cecf8d66d
parent43df08bf75b5188386347577b52f97c55fd91615 (diff)
downloadaur-d172a5bb8e571dd9d4c3a2767f54982ab61b2537.tar.gz
general changes:
- no conflict with ninja-ide 2.3 due to the different python version - wrote and added setup.py - this allows to compile and optimize the files - higher resolution icon - no need to work around the casual way for downloading git repos
-rw-r--r--.SRCINFO15
-rw-r--r--MANIFEST.in2
-rw-r--r--PKGBUILD59
-rw-r--r--setup.py37
4 files changed, 76 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 473db5770c96..9544bd7b96cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = ninja-ide-git
- pkgdesc = Cross-platform IDE focused on Python application development - latest git pull
- pkgver = 20180807
+ pkgdesc = Cross-platform IDE focused on Python application development
+ pkgver = 20180921
pkgrel = 1
url = http://ninja-ide.org
arch = any
- license = GPL
+ license = GPL3
+ makedepends = python-setuptools
depends = python
depends = python-pyqt5
depends = qt5-declarative
- provides = ninja-ide
- conflicts = ninja-ide
+ source = git+https://github.com/ninja-ide/ninja-ide.git
source = ninja-ide-git.desktop
+ source = setup.py
+ source = MANIFEST.in
+ md5sums = SKIP
md5sums = 8501ff78ec0150270be0f48ee87bddb5
+ md5sums = 9f9a5b9894d192de503bc98969067f56
+ md5sums = e8fd6b8243172d576d032c26d9140285
pkgname = ninja-ide-git
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 000000000000..22decd753a2c
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,2 @@
+graft ninja_ide
+global-exclude *.qmlc *.py[cod] __pycache__
diff --git a/PKGBUILD b/PKGBUILD
index b9aa3ff34b1d..e6c0fdaa22f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,48 +2,43 @@
# Contributor: Federico Cinelli <cinelli.federico@gmail.com>
pkgname=ninja-ide-git
-pkgver=20180807
+pkgver=20180921
pkgrel=1
-pkgdesc="Cross-platform IDE focused on Python application development - latest git pull"
+pkgdesc="Cross-platform IDE focused on Python application development"
arch=('any')
url="http://ninja-ide.org"
-license=('GPL')
+license=('GPL3')
depends=('python' 'python-pyqt5' 'qt5-declarative')
-provides=('ninja-ide')
-conflicts=('ninja-ide')
-source=(ninja-ide-git.desktop)
-md5sums=('8501ff78ec0150270be0f48ee87bddb5')
-
-_gitroot="https://github.com/ninja-ide/ninja-ide.git"
-_gitname="ninja-ide"
-
-
-prepare() {
- cd "$startdir"
- msg "Connecting to GIT server...."
-
- if [ -d "$_gitname" ] ; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
-}
+makedepends=('python-setuptools')
+source=("git+https://github.com/ninja-ide/ninja-ide.git"
+ "ninja-ide-git.desktop"
+ "setup.py"
+ "MANIFEST.in")
+md5sums=('SKIP'
+ '8501ff78ec0150270be0f48ee87bddb5'
+ '9f9a5b9894d192de503bc98969067f56'
+ 'e8fd6b8243172d576d032c26d9140285')
pkgver() {
- cd "$startdir/$_gitname"
+ cd "$srcdir/ninja-ide"
git log -1 --date=short --pretty=format:%ad | sed 's/-//g'
}
+prepare() {
+ cd "$srcdir/ninja-ide"
+ rm -rf build *.egg-info
+ rm -rf ninja_tests ninja_profiling
+}
package() {
- install -Dm644 "$startdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "$startdir/ninja-ide/ninja_ide/img/ninja_icon.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
+ cd "$srcdir/ninja-ide"
+
+ cp $srcdir/setup.py .
+ cp $srcdir/MANIFEST.in .
- mkdir -p "$pkgdir/usr/lib/python3.7/site-packages"
- cp -a "$startdir/ninja-ide/ninja_ide" "$pkgdir/usr/lib/python3.7/site-packages"
+ python3 setup.py install --root="$pkgdir" -O1
- mkdir -p "$pkgdir/usr/bin"
- cp -a "$startdir/ninja-ide/ninja-ide.py" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$srcdir/ninja-ide/ninja-ide.py" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/ninja-ide/ninja_ide/images/icon.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
+ install -Dm644 "$srcdir/ninja-ide/icon.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
}
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..32c78742b0a2
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,37 @@
+from setuptools import setup, find_packages
+
+setup(name='Ninja-IDE',
+ version='2.3+dev',
+ description='Cross-platform IDE focused on Python application development',
+ author='The Ninja IDE Developers',
+ url='http://ninja-ide.org',
+ download_url='https://github.com/ninja-ide/ninja-ide',
+ license='GPLv3+',
+ packages=find_packages(),
+ python_requires='>=3.4',
+ install_requires=['pyqt5'],
+ extra_require={'tests': ['pytest', 'pytest-qt']},
+ include_package_data=True,
+ zip_safe=False,
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Topic :: Software Development',
+ 'Topic :: Text Editors',
+ 'Topic :: Text Editors :: Integrated Development Environments (IDE)',
+ ],
+ project_urls={
+ 'Bug Reports': 'https://github.com/ninja-ide/ninja-ide/issues',
+ 'Sourcecode': 'https://github.com/ninja-ide/ninja-ide',
+ 'Donations': 'https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=8TESZPNRD59H6',
+ 'Flattr': 'https://button.flattr.com/flattr/T1gcadsvoNbmRMQHL4xPIVKnuJLkWephrcCdTfmySQ8%7Cuxo2PSTXxruOKExXGGt_IjdY-WOfiu4OG1P5zehE2_Y%7CQHSnMfEto2NAuneuPPhKdDW_D9Rjx0qfLlJfFiBcvkBvrLcR2Hra5cAY22-I6azaUP-sbIWpPMAjLmJbk6LQXrQQQ6DhmxTg2-7Dsyjyhgfatj6OuBEB09F9-0htyFOd',
+ },)