summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2018-03-22 15:52:35 +0100
committerSeverin Glöckner2018-03-22 15:52:35 +0100
commite7a6623beb5d06cccc5bdfa5534cefb184609a84 (patch)
tree50da27bef769226d9a9f634711a96332450b558c
downloadaur-e7a6623beb5d06cccc5bdfa5534cefb184609a84.tar.gz
inital commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD49
-rw-r--r--ninja-ide-git.desktop10
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4835f319ef05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ninja-ide-git
+ pkgdesc = Cross-platform IDE focused on Python application development - latest git pull
+ pkgver = 20180317
+ pkgrel = 1
+ url = http://ninja-ide.org
+ arch = any
+ license = GPL
+ depends = python
+ depends = python-pyqt5
+ depends = qt5-declarative
+ provides = ninja-ide
+ conflicts = ninja-ide
+ source = ninja-ide-git.desktop
+ md5sums = ac8287a7d40e2584f3191c5784fb7216
+
+pkgname = ninja-ide-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35516558633f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer Severin Glöckner <severin dot gloeckner at stud dot htwk minus leipzig dot de>
+# Contributor: Federico Cinelli <cinelli.federico@gmail.com>
+
+pkgname=ninja-ide-git
+pkgver=20180322
+pkgrel=1
+pkgdesc="Cross-platform IDE focused on Python application development - latest git pull"
+arch=('any')
+url="http://ninja-ide.org"
+license=('GPL')
+depends=('python' 'python-pyqt5' 'qt5-declarative')
+provides=('ninja-ide')
+conflicts=('ninja-ide')
+source=(ninja-ide-git.desktop)
+md5sums=('ac8287a7d40e2584f3191c5784fb7216')
+
+_gitroot="https://github.com/ninja-ide/ninja-ide.git"
+_gitname="ninja-ide"
+
+
+prepare() {
+ cd $startdir
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+}
+
+pkgver() {
+ cd $startdir/$_gitname
+ git log -1 --date=short --pretty=format:%ad | sed 's/-//g'
+}
+
+package() {
+ install -Dm644 "$startdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$startdir/ninja-ide/ninja_ide/img/ninja_icon.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
+
+ mkdir -p "$pkgdir/usr/lib/python3.6/site-packages"
+ cp -a "$startdir/ninja-ide/ninja_ide" "$pkgdir/usr/lib/python3.6/site-packages"
+
+ mkdir -p "$pkgdir/usr/bin"
+ cp -a "$startdir/ninja-ide/ninja-ide.py" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/ninja-ide-git.desktop b/ninja-ide-git.desktop
new file mode 100644
index 000000000000..6d8d68ffff63
--- /dev/null
+++ b/ninja-ide-git.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Ninja IDE
+Comment=A Python IDE
+Exec=ninja-ide-git %F
+Icon=ninja-ide-git
+Terminal=false
+Type=Application
+Categories=Development;
+StartupNotify=true
+MimeType=application/x-python;application/x-ninja-ide;