summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Hernandez-Cerdan2018-12-11 12:46:58 -0500
committerPablo Hernandez-Cerdan2018-12-11 12:46:58 -0500
commit059590dc4d9dbde531a2ace1ae82431df8fca125 (patch)
treecdf1e81aec280ec47108632b38c7658812fb86b0
parentf7bac675da5f1981fc4728179e6a167d8bc68119 (diff)
downloadaur-059590dc4d9dbde531a2ace1ae82431df8fca125.tar.gz
Update to 1.8.2.g81279
Released Oct8 2018 https://github.com/Kitware/ninja/commit/81279592028c9e601f91c742fc7720d234243266
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00226bf85706..738daea625d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,18 +16,18 @@ conflicts=(ninja)
license=(Apache)
depends=(gcc-libs)
makedepends=(python2 re2c emacs-nox)
-source=(ninja-$pkgver.g3bbbe.kitware.dyndep-1.jobserver-1.zip::https://github.com/Kitware/ninja/archive/v$pkgver.g3bbbe.kitware.dyndep-1.jobserver-1.zip)
-md5sums=('3bb7477df90f4a388ead79a917902710')
-
+version_id=g81279
+source=(ninja-$pkgver.$version_id.kitware.dyndep-1.jobserver-1.zip::https://github.com/Kitware/ninja/archive/v$pkgver.$version_id.kitware.dyndep-1.jobserver-1.zip)
+md5sums=('35cf0d20b0d79c664f9637b1cf145cd2')
build() {
- cd ninja-$pkgver.g3bbbe.kitware.dyndep-1.jobserver-1
+ cd ninja-$pkgver.$version_id.kitware.dyndep-1.jobserver-1
python2 configure.py --bootstrap
emacs -Q --batch -f batch-byte-compile misc/ninja-mode.el
}
check() {
- cd ninja-$pkgver.g3bbbe.kitware.dyndep-1.jobserver-1
+ cd ninja-$pkgver.$version_id.kitware.dyndep-1.jobserver-1
python2 ./configure.py
./ninja ninja_test
@@ -35,7 +35,7 @@ check() {
}
package() {
- cd ninja-$pkgver.g3bbbe.kitware.dyndep-1.jobserver-1
+ cd ninja-$pkgver.$version_id.kitware.dyndep-1.jobserver-1
install -m755 -D ninja "$pkgdir/usr/bin/ninja"
install -m644 -D doc/manual.asciidoc "$pkgdir/usr/share/doc/ninja/manual.asciidoc"