summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Hernandez-Cerdan2019-02-04 12:16:00 -0500
committerPablo Hernandez-Cerdan2019-02-04 12:16:00 -0500
commit969f52f5a11631488d90084a7bebbd74204ed49c (patch)
tree029eb1ba151978ee8834dfb5cba654d353625e4f
parentcef3da1cd070927c17e0b5cfd58fb2312fc71ab1 (diff)
downloadaur-969f52f5a11631488d90084a7bebbd74204ed49c.tar.gz
Update to v1.9.0.g5b44b
https://github.com/Kitware/ninja/releases/tag/v1.9.0.g5b44b.kitware.dyndep-1.jobserver-1 Remove emacs as a makedepends, make it optdepends instead.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab1a3f18dc5a..cc2c53370207 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = ninja-kitware
pkgdesc = Small build system with a focus on speed - Kitware version with JobServer and Fortran compatibility
pkgver = 1.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Kitware/ninja
arch = x86_64
license = Apache
makedepends = python2
makedepends = re2c
- makedepends = emacs-nox
depends = gcc-libs
+ optdepends = emacs
provides = ninja
conflicts = ninja
- source = ninja-1.9.0.gad558.kitware.dyndep-1.jobserver-1.zip::https://github.com/Kitware/ninja/archive/v1.9.0.gad558.kitware.dyndep-1.jobserver-1.zip
- md5sums = 014cd869dfc9975ed4a9262682375bb4
+ source = ninja-1.9.0.g5b44b.kitware.dyndep-1.jobserver-1.zip::https://github.com/Kitware/ninja/archive/v1.9.0.g5b44b.kitware.dyndep-1.jobserver-1.zip
+ md5sums = eb90758262d361d68af1bb6d2de856ca
pkgname = ninja-kitware
diff --git a/PKGBUILD b/PKGBUILD
index 225ae518c625..0d0d229cd175 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=ninja-kitware
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='Small build system with a focus on speed - Kitware version with JobServer and Fortran compatibility'
arch=(x86_64)
url='https://github.com/Kitware/ninja'
@@ -15,15 +15,18 @@ provides=(ninja)
conflicts=(ninja)
license=(Apache)
depends=(gcc-libs)
-makedepends=(python2 re2c emacs-nox)
-version_id=gad558
+makedepends=(python2 re2c)
+optdepends=(emacs)
+version_id=g5b44b
source=(ninja-$pkgver.$version_id.kitware.dyndep-1.jobserver-1.zip::https://github.com/Kitware/ninja/archive/v$pkgver.$version_id.kitware.dyndep-1.jobserver-1.zip)
-md5sums=('014cd869dfc9975ed4a9262682375bb4')
+md5sums=('eb90758262d361d68af1bb6d2de856ca')
build() {
cd ninja-$pkgver.$version_id.kitware.dyndep-1.jobserver-1
python2 configure.py --bootstrap
- emacs -Q --batch -f batch-byte-compile misc/ninja-mode.el
+ if [ -x "$(command -v emacs)" ]; then
+ emacs -Q --batch -f batch-byte-compile misc/ninja-mode.el
+ fi
}
check() {
@@ -41,11 +44,12 @@ package() {
install -m644 -D doc/manual.asciidoc "$pkgdir/usr/share/doc/ninja/manual.asciidoc"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/ninja/COPYING"
- install -m644 -D misc/ninja-mode.el "$pkgdir/usr/share/emacs/site-lisp/ninja-mode.el"
- install -m644 -D misc/ninja-mode.elc "$pkgdir/usr/share/emacs/site-lisp/ninja-mode.elc"
+ if [ -x "$(command -v emacs)" ]; then
+ install -m644 -D misc/ninja-mode.el "$pkgdir/usr/share/emacs/site-lisp/ninja-mode.el"
+ install -m644 -D misc/ninja-mode.elc "$pkgdir/usr/share/emacs/site-lisp/ninja-mode.elc"
+ fi
install -m644 -D misc/ninja.vim "$pkgdir/usr/share/vim/vimfiles/syntax/ninja.vim"
install -m644 -D misc/bash-completion "$pkgdir/usr/share/bash-completion/completions/ninja"
install -m644 -D misc/zsh-completion "$pkgdir/usr/share/zsh/site-functions/_ninja"
}
-md5sums=('014cd869dfc9975ed4a9262682375bb4')