aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2016-09-26 19:36:45 -0400
committerGI_Jack2016-09-26 19:36:45 -0400
commite9f989fc8afaeff93e454c8ff892d83749aaa090 (patch)
tree5c674882679b635768ebcb8357bc354b2fdde29f
downloadaur-e9f989fc8afaeff93e454c8ff892d83749aaa090.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
-rw-r--r--ninjaos-bootandnuke.install29
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b932a3f6ac73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Sep 26 22:39:18 UTC 2016
+pkgbase = ninjaos-bootandnuke
+ pkgdesc = Ninja Boot'n'Nuke. Boot'n'Nuke implemented as an initcpio image.
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://ninjaos.org
+ install = ninjaos-bootandnuke.install
+ arch = any
+ groups = ninjaos
+ license = GPL3
+ depends = mkinitcpio
+ depends = syslinux
+ depends = parted
+ depends = dosfstools
+ optdepends = hdparm: ATA Security-Erase command
+ provides = mkinitcpio-nban
+ conflicts = mkinitcpio-nban
+ replaces = mkinitcpio-nban
+ source = http://ninjaos.org/downloads/projects/ninjaos-bootandnuke-1.2.tar.gz
+ sha256sums = ac9c780316ef2056927647badefcf828f52a7d108d334ff7a53305adfd5faa72
+
+pkgname = ninjaos-bootandnuke
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80ac0d73e7bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+
+# This is the package build for the tools to build nban and the shuriken
+# This was originally developed for Ninja OS, but has been back ported to Arch
+# Linux.
+
+# Lets be very clear in what "Boot'n'Nuke" means. It means it scrubs all data
+# from all attached storage media upon boot. This is a security tool meant to
+# end of life computers so they can be disposed of without the fear of data
+# retrieval by an attacker. Unlike "Darik's Boot'n'Nuke", which is somewhat
+# complex, Ninja Boot'n'Nuke is very simple with no options. It is based on
+# Arch Linux, and follows the Arch Way. Simple, written in shell code, and
+# re-uses existing Arch Linux features.
+
+# Further more, this package can also create "shurikens", or a single use nban
+# on a stick with extlinux bootloader. The tool allows for custom kernels, and
+# in the future, isolinux and pxelinux, so that the user can make a custom
+# shuriken for any hardware.(see shuriken_forge --help)
+
+# This is very much a valid security tool, and its very well documented.
+
+pkgname=ninjaos-bootandnuke
+pkgver=1.2
+pkgrel=1
+pkgdesc="Ninja Boot'n'Nuke. Boot'n'Nuke implemented as an initcpio image."
+url="http://ninjaos.org/projects.html#bootandnuke"
+arch=('any')
+license=('GPL3')
+groups=('ninjaos')
+depends=('mkinitcpio' 'syslinux' 'parted' 'dosfstools')
+optdepends=('hdparm: ATA Security-Erase command')
+install="${pkgname}.install"
+replaces=("mkinitcpio-nban")
+conflicts=("mkinitcpio-nban")
+provides=("mkinitcpio-nban")
+source=(http://ninjaos.org/downloads/projects/"${pkgname}-${pkgver}.tar.gz")
+sha256sums=('ac9c780316ef2056927647badefcf828f52a7d108d334ff7a53305adfd5faa72')
+validpgpkeys=('D5E76841665A4408D73C2D8796FD6113A1F8331E')
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cp -ra . "${pkgdir}"
+}
+
diff --git a/ninjaos-bootandnuke.install b/ninjaos-bootandnuke.install
new file mode 100644
index 000000000000..cdfcdb4aa285
--- /dev/null
+++ b/ninjaos-bootandnuke.install
@@ -0,0 +1,29 @@
+#!/usr/bin/bash
+post_install() {
+ ln -s /usr/share/ninjaos/shuriken_forge.sh /usr/bin/shuriken_forge
+ package_help
+}
+
+post_upgrade() {
+ package_help
+}
+
+pre_remove(){
+ rm -f /usr/bin/shuriken_forge
+}
+
+package_help() {
+ cat << EOF
+ =Ninja Boot and Nuke=
+Spun off from Ninja OS(http://ninjaos.org) as a stand along package. This
+package has both the mkinitcpio profile for NBAN, and the shuriken creation tool
+.
+
+* Build NBAN: mkinitcpio -p nban
+
+* Build a shuriken: shuriken_forge </dev/sdX>
+
+See shuriken_forge --help for more information.
+
+EOF
+}