aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2017-01-08 16:18:30 -0500
committerGI_Jack2017-01-08 16:18:30 -0500
commitecadd7622737561d59c36b2e8e9c96ed079c4124 (patch)
tree8abc92b797988fce302836d96c636c1b1388475a
parentdb4a8dadc4542c32fcce3a1a1efcd20cf05cc825 (diff)
downloadaur-ecadd7622737561d59c36b2e8e9c96ed079c4124.tar.gz
bump for version 1.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--README45
3 files changed, 57 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 818682fcb4e3..4bcf361cce4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Sep 27 00:05:21 UTC 2016
+# Sun Jan 8 21:15:53 UTC 2017
pkgbase = ninjaos-bootandnuke
pkgdesc = Ninja Boot'n'Nuke. Boot'n'Nuke implemented as an initcpio image.
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
url = http://ninjaos.org/projects.html#bootandnuke
install = ninjaos-bootandnuke.install
@@ -17,8 +17,10 @@ pkgbase = ninjaos-bootandnuke
provides = mkinitcpio-nban
conflicts = mkinitcpio-nban
replaces = mkinitcpio-nban
- source = http://ninjaos.org/downloads/projects/ninjaos-bootandnuke-1.2.tar.gz
- sha256sums = b4dd8fad52b2e6201f8976bc48dcabfa65b54dac76d6f111374ce5d5631e0efd
+ source = http://ninjaos.org/downloads/projects/ninjaos-bootandnuke-1.3.tar.gz
+ source = README
+ sha256sums = b121311063c7ecaa971d1786e5f3dcc8278c1e515c7969689b48ea05e438fb7c
+ sha256sums = 1b28d8f101675d9c6c915df9f36d9a417fa38ce96561570f65e077848a7d4aaa
pkgname = ninjaos-bootandnuke
diff --git a/PKGBUILD b/PKGBUILD
index 43ae14698b31..f9147b476004 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@
# This is very much a valid security tool, and its very well documented.
pkgname=ninjaos-bootandnuke
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="Ninja Boot'n'Nuke. Boot'n'Nuke implemented as an initcpio image."
url="http://ninjaos.org/projects.html#bootandnuke"
@@ -33,11 +33,13 @@ install="${pkgname}.install"
replaces=("mkinitcpio-nban")
conflicts=("mkinitcpio-nban")
provides=("mkinitcpio-nban")
-source=(http://ninjaos.org/downloads/projects/"${pkgname}-${pkgver}.tar.gz")
-sha256sums=('b4dd8fad52b2e6201f8976bc48dcabfa65b54dac76d6f111374ce5d5631e0efd')
+source=("http://ninjaos.org/downloads/projects/${pkgname}-${pkgver}.tar.gz"
+ "README")
+sha256sums=('b121311063c7ecaa971d1786e5f3dcc8278c1e515c7969689b48ea05e438fb7c'
+ '1b28d8f101675d9c6c915df9f36d9a417fa38ce96561570f65e077848a7d4aaa')
validpgpkeys=('D5E76841665A4408D73C2D8796FD6113A1F8331E')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
cp -ra . "${pkgdir}"
+ cp "${srcdir}/README" "${pkgdir}/README"
}
-
diff --git a/README b/README
new file mode 100644
index 000000000000..4d83e48feaf0
--- /dev/null
+++ b/README
@@ -0,0 +1,45 @@
+ -= Ninja Boot and Nuke =-
+
+Ninja Boot and Nuke is and "End of Life" solution that is built around Arch
+native tools. The end result is to wipe all data from all attached storage
+media by zerofilling them. If SATA secure erase is available, then that is used
+instead. This will secure data off machines which are no longer in use, but
+have sensative data, for allow for their disposal.
+
+The core NBAN image is an initcpio profile, that loads storage drivers, and then
+uses dd in parallel to overwrite all drives with zeros and then reboots.
+
+There are several ways this can be utilized.
+
+1. Compile nban directly with mkinitcpio
+
+# mkinitcpio -p nban
+
+You can then set nban.img as initrd= at boot time via bootloader config.
+
+2. "Shuriken"
+
+The Ninja "Shuriken" is nban.img plus a base extlinux bootloader on a flash
+drive. to make a shuriken, you can use the shuriken_forge script. Where sdX is
+a blank flash drive. you can use this to wipe any computer that boots off a
+flash drive, that is also capable of running arch linux.
+
+$ shuriken_forge </dev/sdX>
+
+Please note, that shurikens are not intellegent and will overwrite themselves.
+
+3. reboot_nuke.sh
+
+If you are using syslinux as your boot loader, you can use reboot_nuke.sh to
+overwrite your bootloader and reboot into boot and nuke. reboot_nuke_press.sh
+is designed to be tied to a button that will nuke after a certain about of
+repeated button presses. This is for tying to keyboard shortcuts. You can use
+these to santize your Arch workstation quickly in case of an event requiring
+immediate santiation of data
+
+The default is 3 button presses in 0.8 seconds. these scripts are found in:
+
+/usr/share/ninjaos/reboot_nuke.sh
+/usr/share/ninjaos/reboot_nuke_press.sh
+
+