summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Smidt2020-04-11 08:53:14 -0600
committerJoseph Smidt2020-04-11 08:53:14 -0600
commit03c58bb0ead6458049d67e8bedc35c8eed02a751 (patch)
treeb93a4c40b6a4e32e5b91c70f86593d322df181ec
downloadaur-03c58bb0ead6458049d67e8bedc35c8eed02a751.tar.gz
Initial Upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f0838517c13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nishang-git
+ pkgdesc = A collection of scripts and payloads which enables usage of PowerShell for offensive security.
+ pkgver = r335.eb25ca3
+ pkgrel = 1
+ url = https://github.com/samratashok/nishang
+ arch = any
+ license = GPL
+ makedepends = git
+ conflicts = nishang
+ source = nishang-git::git+https://github.com/samratashok/nishang
+ sha256sums = SKIP
+
+pkgname = nishang-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4e214b2f405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Joseph Smidt <josephsmidt@gmail.com>
+pkgname=nishang-git
+pkgver=r335.eb25ca3
+pkgrel=1
+pkgdesc="A collection of scripts and payloads which enables usage of PowerShell for offensive security."
+arch=('any')
+url="https://github.com/samratashok/nishang"
+license=('GPL')
+makedepends=('git')
+conflicts=('nishang')
+
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -dm0755 "${pkgdir}/usr/share/nishang"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/nishang/LICENSE"
+ cp -ar --no-preserve=ownership ./* "${pkgdir}/usr/share/nishang"
+}