summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshyam2023-09-03 01:32:17 +0530
committershyam2023-09-03 01:32:17 +0530
commitce67e3fa0642cda8300eb1ad7fe6c1c80345d49e (patch)
tree253bd3e53b6413d9b3f2634e81c77a8d605d6a25
downloadaur-ce67e3fa0642cda8300eb1ad7fe6c1c80345d49e.tar.gz
Nishang Scripts
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8e1c614dbd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nishang-scripts
+ pkgdesc = Nishang is a framework and collection of scripts and payloads used during penetration testing tasks.
+ pkgver = 0.7.6.r54.gd87229d
+ pkgrel = 1
+ url = https://github.com/samratashok/nishang
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = powershell
+ provides = nishang-scripts
+ conflicts = nishang-git
+ source = git+https://github.com/samratashok/nishang.git#commit=d87229d2112456470ad30a50edbf312463f2b09a
+ sha256sums = SKIP
+
+pkgname = nishang-scripts
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bf2fc3e72c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Shyam <contact at via dot aur>
+pkgname=nishang-scripts
+_pkgver=nishang
+pkgver=0.7.6.r54.gd87229d
+pkgrel=1
+pkgdesc="Nishang is a framework and collection of scripts and payloads used during penetration testing tasks."
+arch=('any')
+url="https://github.com/samratashok/nishang"
+license=('MIT')
+depends=('powershell')
+makedepends=('git')
+provides=('nishang-scripts')
+conflicts=('nishang-git')
+
+source=("git+https://github.com/samratashok/nishang.git#commit=d87229d2112456470ad30a50edbf312463f2b09a")
+
+pkgver() {
+ cd "$_pkgver"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgver}"
+ install -dm0755 "${pkgdir}/usr/share/nishang"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/nishang/LICENSE"
+ cp -ar --no-preserve=ownership ./* "${pkgdir}/usr/share/nishang"
+}
+sha256sums=('SKIP')