summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDušan Simić2022-07-15 21:03:04 +0200
committerDušan Simić2022-07-15 21:03:04 +0200
commitf8b4c123ac725211578cd4cc94f11981320df5bd (patch)
treeb33acd274378bf4e2827d1f3d76225b01700b0d4
downloadaur-f8b4c123ac725211578cd4cc94f11981320df5bd.tar.gz
Add all files
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59a135afecc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = nitch
+ pkgdesc = Incredibly fast system fetch written in nim
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/unxsh/nitch
+ arch = x86_64
+ license = MIT
+ makedepends = nim
+ source = git+https://github.com/unxsh/nitch#commit=a18ed4d3e88f2a2790503faad7f639aae0ab5b7d
+ md5sums = SKIP
+
+pkgname = nitch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94f4c140f1da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
+
+pkgname=nitch
+pkgver=0.1.4
+_commit=a18ed4d3e88f2a2790503faad7f639aae0ab5b7d
+pkgrel=1
+pkgdesc="Incredibly fast system fetch written in nim"
+arch=(x86_64)
+url=https://github.com/unxsh/nitch
+license=(MIT)
+makedepends=(nim)
+source=("git+$url#commit=$_commit")
+md5sums=(SKIP)
+
+build() {
+ cd "$pkgname"
+ nimble build
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 -t "$pkgdir/usr/bin" "$pkgname"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}