summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Krahl2019-04-19 22:10:28 +0200
committerRobin Krahl2019-04-19 22:10:28 +0200
commite9f3cf4508ced3a754bc8d1188c6e90f0e7ad601 (patch)
tree117fd60ba4e9b16ac488daa7744956c7ed3efdf8
parentc23fdd226858c4a49e3eab51419843d66f8e4a69 (diff)
downloadaur-e9f3cf4508ced3a754bc8d1188c6e90f0e7ad601.tar.gz
Remove --frozen flag from cargo invocation
I used to call cargo with the --frozen flag to avoid unnecessary queries to crates.io. Unforunately, this does only work if you previously queried crates.io (thanks to Unb0rn for the bug report). Therefore this patch removes the --frozen flag and bumps the package version to 0.2.3-2.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb8d2f63408f..b86e0f8b62c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nitrocli
pkgdesc = Command-line interface for Nitrokey devices
pkgver = 0.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/d-e-s-o/nitrocli
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index b58065bb95f2..8a4e36f9e7f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Robin Krahl <robin.krahl@ireas.org>
pkgname=nitrocli
pkgver=0.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="Command-line interface for Nitrokey devices"
arch=('x86_64')
url="https://github.com/d-e-s-o/nitrocli"
@@ -24,7 +24,7 @@ EOF
build() {
cd "$pkgname-$pkgver/nitrocli"
export USE_SYSTEM_LIBNITROKEY=1
- cargo build --release --frozen
+ cargo build --release
}
package() {