summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2018-01-02 16:49:45 +0100
committerÉtienne Deparis2018-01-02 16:49:45 +0100
commit3ba5ff482d3d78e3907ac2a09936a313bd402e85 (patch)
tree331af5575f351e1cdf5db0c317e72fec777eece8
parent2247a29cd8460d8a92f44861497fe97cd99fce7a (diff)
downloadaur-3ba5ff482d3d78e3907ac2a09936a313bd402e85.tar.gz
New version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6687f50ded7e..b28a138eefe4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by makepkg 5.0.2
-# Thu Oct 12 20:01:35 UTC 2017
+# Tue Jan 2 15:49:31 UTC 2018
pkgbase = nitrokey-app
pkgdesc = Nitrokey management application
- pkgver = 1.1
- pkgrel = 5
+ pkgver = 1.2
+ pkgrel = 1
url = https://www.nitrokey.com
install = nitrokey-app.install
arch = i686
@@ -13,10 +13,10 @@ pkgbase = nitrokey-app
makedepends = qt5-tools
depends = qt5-base
depends = hicolor-icon-theme
- depends = libnitrokey
- source = nitrokey-app-1.1.tar.gz::https://github.com/Nitrokey/nitrokey-app/archive/v1.1.tar.gz
+ depends = libnitrokey-git
+ source = nitrokey-app-1.2.tar.gz::https://github.com/Nitrokey/nitrokey-app/archive/v1.2.tar.gz
source = cppcodec.tar.gz::https://github.com/tplgy/cppcodec/archive/61d9b044d6644293f99fb87dfadc15dcab951bd9.tar.gz
- sha256sums = 7501af813721b22c6f859600fd42c7269be60f2da5d0f33cf90e68c19e3f1893
+ sha256sums = 652538d6a9ce51cb274f45c7a5198689da549eacecff372f5534b5ace458de91
sha256sums = 80c2f0ebc0da7186386f525d798bad0eaf14837c9548d86060b503751193b010
pkgname = nitrokey-app
diff --git a/PKGBUILD b/PKGBUILD
index 034ca698f413..dd07e04c34dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,32 @@
# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
pkgname=nitrokey-app
-pkgver=1.1
-pkgrel=5
+pkgver=1.2
+pkgrel=1
_cppcodecver=61d9b044d6644293f99fb87dfadc15dcab951bd9
pkgdesc="Nitrokey management application"
arch=('i686' 'x86_64')
url="https://www.nitrokey.com"
license=('GPL3')
-depends=('qt5-base' 'hicolor-icon-theme' 'libnitrokey')
+depends=('qt5-base' 'hicolor-icon-theme' 'libnitrokey-git')
makedepends=('cmake' 'qt5-tools')
install=nitrokey-app.install
source=("$pkgname-$pkgver.tar.gz::https://github.com/Nitrokey/nitrokey-app/archive/v$pkgver.tar.gz"
"cppcodec.tar.gz::https://github.com/tplgy/cppcodec/archive/${_cppcodecver}.tar.gz")
-sha256sums=('7501af813721b22c6f859600fd42c7269be60f2da5d0f33cf90e68c19e3f1893'
+sha256sums=('652538d6a9ce51cb274f45c7a5198689da549eacecff372f5534b5ace458de91'
'80c2f0ebc0da7186386f525d798bad0eaf14837c9548d86060b503751193b010')
prepare() {
cd $pkgname-$pkgver
- sed -i 's|DESTINATION ${BASH_COMPLETION_DIR}|DESTINATION share/bash-completion/completions|' \
- CMakeLists.txt
-
- sed -i 's|DESTINATION ${UDEV_MAIN_DIR}|DESTINATION lib/udev/rules.d|' \
- CMakeLists.txt
-
- sed -i '/^add_subdirectory (libnitrokey)$/d' CMakeLists.txt
-
sed -i 's|libnitrokey/LICENSE|/usr/share/licenses/libnitrokey/LICENSE|' \
resources.qrc
- sed -i 's/^LIBNITROKEY= -lnitrokey-static$/LIBNITROKEY= -lnitrokey/' \
- nitrokey-app-qt5.pro
-
- cd libnitrokey
- ln -s /usr/include/libnitrokey include
+ for srcfile in $(grep -rl 'libnitrokey/include/' src); do
+ sed -i 's|^#include \(["<]\)libnitrokey/include/|#include \1libnitrokey/|g' "$srcfile"
+ done
- cd ../3rdparty
+ cd 3rdparty
rmdir cppcodec
ln -s $srcdir/cppcodec-${_cppcodecver} cppcodec
@@ -50,7 +40,7 @@ build() {
cmake . \
-DCMAKE_BUILD_TYPE=Release \
- -DLIBNITROKEY_STATIC=OFF \
+ -DBUILD_SHARED_LIBS=ON \
-DCMAKE_INSTALL_PREFIX=/usr
make
}