summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-11-14 16:12:19 +0100
committerMichael Straube2016-11-14 16:12:19 +0100
commit6dfadf1b404936ace72d178417b9c2585a4329ab (patch)
treed5450eab53aec6284bc38e6395d0da88fd7c85a0
parent3eb52773ddad287180fc3da58b3c816bca24658a (diff)
downloadaur-6dfadf1b404936ace72d178417b9c2585a4329ab.tar.gz
v0.5.1 (use release instead of git sources)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD35
-rw-r--r--nitrokey-app.install4
3 files changed, 22 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50cf68d54ef0..252ef466ca28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = nitrokey-app
pkgdesc = Nitrokey management application
- pkgver = r477.g694e6a5
+ pkgver = 0.5.1
pkgrel = 1
url = https://www.nitrokey.com
install = nitrokey-app.install
arch = i686
arch = x86_64
license = GPL3
- makedepends = git
makedepends = cmake
depends = qt5-base
depends = libusb>=1.0.0
- source = nitrokey-app::git+https://github.com/Nitrokey/nitrokey-app
- sha256sums = SKIP
+ depends = hicolor-icon-theme
+ source = https://github.com/Nitrokey/nitrokey-app/archive/v0.5.1.tar.gz
+ sha1sums = d099841bf01e4d6f47dadf2521a8fcb704be4344
pkgname = nitrokey-app
diff --git a/PKGBUILD b/PKGBUILD
index c3cbf168fe64..2208539bc84c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
pkgname=nitrokey-app
-pkgver=r477.g694e6a5
+pkgver=0.5.1
pkgrel=1
pkgdesc="Nitrokey management application"
arch=('i686' 'x86_64')
url="https://www.nitrokey.com"
license=('GPL3')
-depends=('qt5-base' 'libusb>=1.0.0')
-makedepends=('git' 'cmake')
-source=("${pkgname}::git+https://github.com/Nitrokey/nitrokey-app")
+depends=('qt5-base' 'libusb>=1.0.0' 'hicolor-icon-theme')
+makedepends=('cmake')
install=nitrokey-app.install
-sha256sums=('SKIP')
+source=("https://github.com/Nitrokey/nitrokey-app/archive/v$pkgver.tar.gz")
+sha1sums=('d099841bf01e4d6f47dadf2521a8fcb704be4344')
-pkgver() {
- cd "${pkgname}"
- printf "r%s.g%s" \
- "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
+prepare() {
+ cd $pkgname-$pkgver
+
+ sed -i 's|DESTINATION\ etc/bash_completion.d|DESTINATION\ usr/share/bash-completion/completions|' \
+ CMakeLists.txt
}
build() {
- cd "${pkgname}"
- sed -i 's|/etc/udev/rules.d|/usr/lib/udev/rules.d|g' CMakeLists.txt
- sed -i 's|/etc/bash_completion.d|/usr/share/bash-completion/completions|g' \
- CMakeLists.txt
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DHAVE_LIBAPPINDICATOR=NO
+ cd $pkgname-$pkgver
+
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/ \
+ -DHAVE_LIBAPPINDICATOR=NO
make
}
package() {
- cd "${pkgname}"
- make DESTDIR="${pkgdir}" install
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
}
diff --git a/nitrokey-app.install b/nitrokey-app.install
index 1d8842bbd62b..2ca34623e0ba 100644
--- a/nitrokey-app.install
+++ b/nitrokey-app.install
@@ -1,8 +1,6 @@
post_install() {
/usr/bin/getent group nitrokey >/dev/null 2>&1 || usr/sbin/groupadd -r nitrokey &>/dev/null
udevadm control --reload
- xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
echo "Don't forget to add users to the nitrokey group."
}
@@ -11,8 +9,6 @@ post_upgrade() {
}
post_remove() {
- xdg-icon-resource forceupdate --theme hicolor &> /dev/null
- update-desktop-database -q
if /usr/bin/getent group nitrokey >/dev/null 2>&1; then
/usr/sbin/groupdel nitrokey
fi