summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph J. Thompson2015-08-13 05:16:09 +0200
committerChristoph J. Thompson2015-08-13 05:16:09 +0200
commitedd93e517aa5329392d27eca1717633925fac22a (patch)
tree357caad970b6d941617bd2bf09bbf83e4a0187ab
parent95986660decd96e42aa059f838f687874f800883 (diff)
downloadaur-edd93e517aa5329392d27eca1717633925fac22a.tar.gz
* The udev rules are now in nitrokey-app's repo
* No need to autostart because the applet works with session management. * Build only with Qt 5 * Other cleanups modified: .SRCINFO deleted: 40-nitrokey.rules modified: PKGBUILD deleted: nitrokey-app.desktop
-rw-r--r--.SRCINFO6
-rw-r--r--40-nitrokey.rules19
-rw-r--r--PKGBUILD17
-rw-r--r--nitrokey-app.desktop13
4 files changed, 8 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad31369db961..a2f96bc63fc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nitrokey-app
pkgdesc = Nitrokey management application
- pkgver = r358.g886fed4
+ pkgver = r477.g694e6a5
pkgrel = 1
url = https://www.nitrokey.com
install = nitrokey-app.install
@@ -11,11 +11,7 @@ pkgbase = nitrokey-app
depends = qt5-base
depends = libusb>=1.0.0
source = nitrokey-app::git+https://github.com/Nitrokey/nitrokey-app
- source = 40-nitrokey.rules
- source = nitrokey-app.desktop
sha256sums = SKIP
- sha256sums = 20dff1e02ee899ebfabcbb4b995d5b0f46301969a6ee11668cd37cbef77b95ad
- sha256sums = 6d847e94fb3e81d24765c0d0ad54f375f4943ace9b2144d5dc45e5b159184e94
pkgname = nitrokey-app
diff --git a/40-nitrokey.rules b/40-nitrokey.rules
deleted file mode 100644
index 632f47a1743d..000000000000
--- a/40-nitrokey.rules
+++ /dev/null
@@ -1,19 +0,0 @@
-SUBSYSTEM!="usb", GOTO="gnupg_rules_end"
-ACTION!="add", GOTO="gnupg_rules_end"
-
-# USB SmartCard Readers
-## Crypto Stick 1.2
-ATTR{idVendor}=="20a0", ATTR{idProduct}=="4107", ENV{ID_SMARTCARD_READER}="1", ENV{ID_SMARTCARD_READER_DRIVER}="gnupg", GROUP+="nitrokey", TAG+="uaccess"
-## Nitrokey Pro
-ATTR{idVendor}=="20a0", ATTR{idProduct}=="4108", ENV{ID_SMARTCARD_READER}="1", ENV{ID_SMARTCARD_READER_DRIVER}="gnupg", GROUP+="nitrokey", TAG+="uaccess"
-## Nitrokey Storage
-ATTR{idVendor}=="20a0", ATTR{idProduct}=="4109", ENV{ID_SMARTCARD_READER}="1", ENV{ID_SMARTCARD_READER_DRIVER}="gnupg", GROUP+="nitrokey", TAG+="uaccess"
-## Nitrokey Light
-ATTR{idVendor}=="20a0", ATTR{idProduct}=="4211", ENV{ID_SMARTCARD_READER}="1", ENV{ID_SMARTCARD_READER_DRIVER}="gnupg", GROUP+="nitrokey", TAG+="uaccess"
-
-LABEL="gnupg_rules_end"
-
-# Nitrokey U2F
-ACTION!="add|change", GOTO="u2f_end"
-KERNEL=="hidraw*", SUBSYSTEM=="hidraw", ATTRS{idVendor}=="2581", ATTRS{idProduct}=="f1d0", GROUP+="nitrokey", TAG+="uaccess"
-LABEL="u2f_end"
diff --git a/PKGBUILD b/PKGBUILD
index 8057c0b34945..716212b65a24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
pkgname=nitrokey-app
-pkgver=r358.g886fed4
+pkgver=r477.g694e6a5
pkgrel=1
pkgdesc="Nitrokey management application"
arch=('i686' 'x86_64')
@@ -9,13 +9,9 @@ url="https://www.nitrokey.com"
license=('GPL3')
depends=('qt5-base' 'libusb>=1.0.0')
makedepends=('git')
-source=("${pkgname}::git+https://github.com/Nitrokey/nitrokey-app"
- 40-nitrokey.rules
- nitrokey-app.desktop)
+source=("${pkgname}::git+https://github.com/Nitrokey/nitrokey-app")
install=nitrokey-app.install
-sha256sums=('SKIP'
- 20dff1e02ee899ebfabcbb4b995d5b0f46301969a6ee11668cd37cbef77b95ad
- 6d847e94fb3e81d24765c0d0ad54f375f4943ace9b2144d5dc45e5b159184e94)
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
@@ -26,13 +22,14 @@ pkgver() {
build() {
cd "${pkgname}"
- cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ sed -i 's|/etc/udev/rules.d|/usr/lib/udev/rules.d|g' CMakeLists.txt
+ sed -i 's|/etc/bash_completion.d|/usr/share/bash-completion/completions|g' \
+ CMakeLists.txt
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DHAVE_LIBAPPINDICATOR=NO
make
}
package() {
cd "${pkgname}"
make DESTDIR="${pkgdir}" install
- install -Dm644 "${srcdir}/40-nitrokey.rules" "${pkgdir}/usr/lib/udev/rules.d/40-nitrokey.rules"
- install -Dm644 "${srcdir}/nitrokey-app.desktop" "${pkgdir}/etc/xdg/autostart/nitrokey-app.desktop"
}
diff --git a/nitrokey-app.desktop b/nitrokey-app.desktop
deleted file mode 100644
index 1838deac4f08..000000000000
--- a/nitrokey-app.desktop
+++ /dev/null
@@ -1,13 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-GenericName=Nitrokey management application
-GenericName[de]=Nitrokeyverwaltungsapplikation
-GenericName[fr]=Programme de gestion de la Nitrokey
-Comment=Manage Nitrokey devices
-Comment[de]=Nitrokey Laufwerk verwalten
-Comment[fr]=Gérer des périphériques Nitrokey
-Icon=nitrokey-app
-Exec=nitrokey-app
-Terminal=false
-NoDisplay=true